Hello Guys - Mercedes Benz SLK Forum

New Members Introduce Yourself Here New members come here first!. Update your profile: model, year and location. Post any issues in the relevant section. The team may then post a link to your issue thread in your introduction. User Name must be in plain text, NOT ASCII

 
LinkBack Thread Tools
#1 Old 10-21-2010
Registered Users
 
Join Date: Oct 2010
Posts: 5
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Hello Guys

I'm having trouble with my 2000 slk 230. It ran perfect when i first bought it about 2 years ago. About 3 months ago it began to run kind of rough and the check engine light came on. I researched it and determined that it was the k40 relay. I bought a new one and replaced it instead of repairing the old one(which was burnt and I still have).It started a couple of times but ran even worse. But now it won't start at all. The engine light is off now but it seems like it's not getting any gas. I poured some gas into the throttle body and it started up but as soon as that gas burned it begin to sputter and cough and then it died. It won't start back unless I add gas to the throttle body. I am a female and I don't know much about cars but I can learn. Your help would be greatly appreciated. Oh yea....it has gas in it().
Blk_Apple_Pie is offline  
Sponsored Links
Advertisement
 
#2 Old 10-21-2010
Registered Users
 
Swagman's Avatar
 
Join Date: Oct 2010
Location: Northampton, UK
Vehicle: 12' SLK55 AMG
Other Toys: 15' HYUNDAI SANTA FE
Posts: 921
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Thanks: 77
Thanked 135 Times in 99 Posts
Garage
Hi and welcome to the forum, from a very chilly UK.

I read this forum thread only the other day, talking about the K40 relay, and how the actual PCB the relay sits on sometimes deteriorates and requires re soldering..

The first line goes "Early SLKs suffered from soldered joint failures on the K40 pcb. This mainly affects smooth op and fuel pump."

perhaps have a read of this, and see if the symptoms you have seem similar. They certainly sound similar to me.
Swagman is offline  
#3 Old 10-21-2010
Registered Users
 
Join Date: Oct 2010
Posts: 5
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
The K40 relay WAS bad. It has been replaced with a NEW one. The check engine light went off after it was installed but now it seems to not be getting fuel into the injection system. I was thinking maybe it's the fuel pressure or maybe something as simple as a fuel filter being clogged. At this point my car doesn't start at all without being primed at the throttle body and then it dies after the fuel is consumed.
Blk_Apple_Pie is offline  
 
#4 Old 10-21-2010
Sadly Woolly has passed away

 
Woolly's Avatar
 
Join Date: Jun 2006
Location: Co. Durham, UK
Vehicle: SLK350 MT
Other Toys: CLK 270CDI (Slushbox!!)
Posts: 17,375
Country:
Chats: 1297
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Thanks: 2,912
Thanked 3,515 Times in 2,416 Posts
Garage
Welcome from what was a beautiful top down day in NE England. When you said you changed the K40 relay, did you actually check the PCB that it plugs into? The relay itself is rarely a problem, it's the solder pads on the board that need re-soldering. The initial flow soldering system used was not up to the current being passed through the joints, and they'd over heat, crystalise and you'd end up with a bad/intermittent/dry joints. Simply re-soldering them properly can cure a multitude of sins.






To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

MB SLK 350 Andradite Green (6 speed manual)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Woolly is offline  
#5 Old 10-21-2010
Registered Users
 
Join Date: Oct 2010
Posts: 5
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
I changed the entire component, not the relay itself. It was brand new from a respected dealer of OEM parts. I opened the old one and sure enough one of the joints was burned. So i'm keeping that one as a replacement if the new one ever goes bad.
Blk_Apple_Pie is offline  
#6 Old 10-21-2010
Registered Users
 
GeeJay's Avatar
 
Join Date: Jan 2009
Location: North-West Blighty.....
Vehicle: '16 C250d AMG Estate Premium+ Designo Hyacinth Metalic
Other Toys: Guitars... :-) Formerly '08 SLK200 6sp Palladium
Posts: 5,134
Country:
Chats: 91
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
Thanks: 652
Thanked 793 Times in 574 Posts
Welcome from Blighty......
GeeJay is offline  
#7 Old 10-21-2010
Registered Users
 
Join Date: Oct 2010
Posts: 5
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Thank you Blighty....can you help?
Blk_Apple_Pie is offline  
#8 Old 10-21-2010
Sadly Woolly has passed away

 
Woolly's Avatar
 
Join Date: Jun 2006
Location: Co. Durham, UK
Vehicle: SLK350 MT
Other Toys: CLK 270CDI (Slushbox!!)
Posts: 17,375
Country:
Chats: 1297
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Thanks: 2,912
Thanked 3,515 Times in 2,416 Posts
Garage
Quote:
Originally Posted by Blk_Apple_Pie View Post
I changed the entire component, not the relay itself. It was brand new from a respected dealer of OEM parts. I opened the old one and sure enough one of the joints was burned. So i'm keeping that one as a replacement if the new one ever goes bad.
Have you rechecked the new one to ensure that hasn't burnt out again?






To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

MB SLK 350 Andradite Green (6 speed manual)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Woolly is offline  
#9 Old 10-21-2010
Registered Users
 
Swagman's Avatar
 
Join Date: Oct 2010
Location: Northampton, UK
Vehicle: 12' SLK55 AMG
Other Toys: 15' HYUNDAI SANTA FE
Posts: 921
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Thanks: 77
Thanked 135 Times in 99 Posts
Garage
Well we'll have to have another think about it then if you changed the whole PCB as in the picture below, and not just the relay unit.

I suppose it will be a process of elimination, starting with the cheapest component first...

At least this way you might get a load of new components fitted to your car, or if your lucky, just 1...

Swagman is offline  
#10 Old 10-21-2010
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,144
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
Welcome from New Hampshire. Since you have the old K40 re solder the bad joints and put it back in the car and see if it runs any better. At this point you have nothing to lose.
Livefreeordie is offline  
#11 Old 10-21-2010
Premium Member
 
Dave54's Avatar
 
Join Date: Apr 2008
Location: Portland, Oregon
Vehicle: 2009 SLK 350
Posts: 17,470
Country:
Chats: 2
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Thanks: 1,526
Thanked 1,338 Times in 1,222 Posts
Garage
Welcome from Portland, Oregon.
Dave54 is online now  
#12 Old 10-21-2010
Registered Users

 
alroumi's Avatar
 
Join Date: Jun 2006
Location: GMT+3
Vehicle: Kleemann K2
Posts: 10,721
Country:
Chats: 1
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 1,030
Thanked 922 Times in 634 Posts
Welcome

06 SLK55 AMG (Kleemann K2)
alroumi is offline  
#13 Old 10-21-2010
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,966
Country:
Chats: 38
Mentioned: 473 Post(s)
Tagged: 5 Thread(s)
Quoted: 6579 Post(s)
Thanks: 3,246
Thanked 11,107 Times in 8,460 Posts
Welcome from Valrico, Florida!
And welcome to this great forum!

Please update your location/vehicle (model and yr) in your profile as it helps the members answer any questions you might have based on locale and model and year.
Usercp at the top of page, edit your details, location/vehicle.





If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member or guest will address your question.
If you wish to PM (Private Message) someone, you need 15 posts. To get those 15 posts quickly, just go to the ‘new members introduce yourself here’ section and welcome enough new members listed to obtain your needed posts.
And finally, if you find something useful on your visit here today, perhaps something that saved you time or money, please consider becoming a donating member or make a one-time donation to offset development and operating costs. Even $5 is welcome! At the top of the page, click ‘Donate now’. Thanks!


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#14 Old 10-21-2010
Registered Users
 
Join Date: Oct 2010
Posts: 5
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Thank you guys for a very warm welcome. I appreciate it. I have just repaired my old K40 relay but the problem still exists. Any other suggestions?
Blk_Apple_Pie is offline  
#15 Old 10-25-2010
Premium Member
 
hasontour's Avatar
 
Join Date: May 2009
Location: london
Vehicle: In between slk's!!!
Posts: 13,815
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Thanks: 306
Thanked 761 Times in 748 Posts
Hi from London, it's a top down afternoon, Nice!
sorry to hear about your problems, can't help, but i hope you get it sorted soon!
hasontour is offline  
#16 Old 10-25-2010
Registered Users
 
Join Date: Feb 2010
Location: Santa Monica CA
Vehicle: Black 2002 SLK AMG
Other Toys: Red 1965 Mustang convertible 4bbl V-8, 4spd
Posts: 843
Country:
Chats: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 221
Thanked 216 Times in 142 Posts
Garage
Welcome to the forum from southern california.

Based on your symptoms, sounds like fuel starvation to me. With the replacement K40 board and the the repaired original K40 board still giving you the same symptoms I would recommend checking/changing the fuel filter, fuel pressure regulator and/or the fuel pump. Knowing the fuel pressures and whether the fuel pump is actually running would help to narrow down the problem. Given that your car won't even idle without manually adding gas, I think your fuel pump isnt running. Check the 5 fuses on the K40 board, if they are good (I forget which of the 5 is for the fuel pump), check if your fuel pump is running.

This post has pics which show the 5 15 amp (blue) fuses. One of those 5 15 amp fuses is for the fuel pump:

https://www.slkworld.com/slk-r170-gen...html#post12358
Santamonica SLK32 is offline  
#17 Old 10-25-2010
Premium Member
 
PropDr's Avatar
 
Join Date: Jun 2009
Location: Eugene,OR
Vehicle: 2008 SLK 55 AMG 030 with SC
Other Toys: 2012 Ford Raptor, 06 BMW R1200 RT
Posts: 3,248
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Thanks: 277
Thanked 622 Times in 455 Posts
Garage
Welcome from Eugene, Oregon via SFO


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

My Beautiful Black Walküre (Valkyrie)
PropDr is offline  
#18 Old 11-05-2010
Registered Users
 
Join Date: Jun 2006
Location: Bloomfield Hills Michigan, Spring Hill Florida & Lantana Texas
Vehicle: 2006 SLK55
Other Toys: 2015 Dodge Durabgo RT and 2014 Chrysler 300 SRT
Posts: 3,381
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 213
Thanked 255 Times in 251 Posts
Welcome from Michigan.....
matton is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > General Discussion about Mercedes Benz SLKs > New Members Introduce Yourself Here

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
tail lights needed guys cw0974 Where to get R171 SLK Items 11 09-03-2010 02:53 PM
Brake pads, what are you guys running? xpl0sive General Modifications R171 11 04-25-2010 03:19 PM
Can You Guys Help Me GtoBenz General Discussion 12 01-25-2010 12:45 PM
Hey guys, let's do a SGV-OC meet and drive? (SoCal) cyberdrakon MB Events 75 06-08-2009 03:13 AM
you guys have any recommendations on a forum regarding training noisy dogs? cyberdrakon Off Topic 11 03-28-2008 09:49 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.