Time Slips! - Mercedes Benz SLK Forum

Motorsports Autocross, Track, Racing, and Competition Discussion

 14Likes
  • 2 Post By UltSLK55
  • 3 Post By jet_fl
  • 1 Post By UltSLK55
  • 1 Post By jet_fl
  • 1 Post By UltSLK55
  • 1 Post By Grip-Grip
  • 2 Post By Grip-Grip
  • 1 Post By Grip-Grip
  • 1 Post By Grip-Grip
  • 1 Post By jet_fl
 
LinkBack Thread Tools
#1 Old 02-04-2019
Registered Users
 
Join Date: Mar 2017
Location: TN
Vehicle: Supercharged 2005 SLK55
Posts: 153
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Thanks: 3
Thanked 10 Times in 6 Posts
(Thread Starter)
Time Slips!

This can be a thread for drag racing Time Slips if others care to add.



We had a warm enough day for the track to open. It was 65degrees on the attached run (about 1250 DA), running Michelin Pilot Sport 4S (about a year or so old). My car was #42 .


The [email protected] in the 1/8 extrapolates to about an [email protected] in the 1/4 mile ... that's from just looking at a bunch of times on dragtimes.com. I know it doesn't actually count as that.
Attached Images
File Type: jpg [email protected] (28.6 KB, 4 views)
DAVIETHESCAFF and Idiot101 like this.
UltSLK55 is offline  
Sponsored Links
Advertisement
 
#2 Old 02-04-2019
Registered Users
 
Join Date: Sep 2017
Location: Orlando
Vehicle: 05 SLK55 & 06 Kleemann 55K S8
Other Toys: 335Xi (modded) Suzuki GSXR1000
Posts: 509
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 154 Post(s)
Thanks: 4
Thanked 45 Times in 45 Posts
1.7 60' is very nice! This was ESP off, right? Best I got was a 1.9 I believe. I ran a 12.3 at 116, but couldn't get a clean run. I have since changed the MAF and all is good now. I am about due for tires, so I will head out once I get those on.
Idiot101, UltSLK55 and HawkX66 like this.
jet_fl is offline  
#3 Old 02-05-2019
Registered Users
 
Join Date: Mar 2017
Location: TN
Vehicle: Supercharged 2005 SLK55
Posts: 153
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Thanks: 3
Thanked 10 Times in 6 Posts
(Thread Starter)
Quote:
Originally Posted by jet_fl View Post
1.7 60' is very nice! This was ESP off, right? Best I got was a 1.9 I believe. I ran a 12.3 at 116, but couldn't get a clean run. I have since changed the MAF and all is good now. I am about due for tires, so I will head out once I get those on.

ESP was on, but there was just a little bit of spin. I have a Quaife LSD, Kleemann s/c, Kleemann headers, Kleemann cams (10hp, pretty much a waste of money), ported heads from a local shop (no hp, definitely a waste of money), and a RaceIQ tune. It dynoed at about 405/420 on two different dynojets (SAE correction), at about 5.5psi.


What was your 1/8 trap on that, if you recall?
Idiot101 likes this.
UltSLK55 is offline  
 
#4 Old 02-05-2019
Registered Users
 
Join Date: Sep 2017
Location: Orlando
Vehicle: 05 SLK55 & 06 Kleemann 55K S8
Other Toys: 335Xi (modded) Suzuki GSXR1000
Posts: 509
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 154 Post(s)
Thanks: 4
Thanked 45 Times in 45 Posts
Quote:
Originally Posted by UltSLK55 View Post
ESP was on, but there was just a little bit of spin. I have a Quaife LSD, Kleemann s/c, Kleemann headers, Kleemann cams (10hp, pretty much a waste of money), ported heads from a local shop (no hp, definitely a waste of money), and a RaceIQ tune. It dynoed at about 405/420 on two different dynojets (SAE correction), at about 5.5psi.


What was your 1/8 trap on that, if you recall?
Sorry I don't and I didn't save the slip because I wasn't very happy with it and I couldn't get a clean run in. Our cars are very similar except I have the kleemann full exhaust, but have the inferior kleemann LSD. It does work pretty good in a straight line, but not as well off corners. I am guessing my tune is not optimal either, the car seems to run very rich. I have been guessing my car is 400-420whp, so it sounds like I was pretty much spot on. The 596hp claim from Kleemann is nuts.
Idiot101 likes this.
jet_fl is offline  
#5 Old 02-19-2019
Registered Users
 
Join Date: Mar 2017
Location: TN
Vehicle: Supercharged 2005 SLK55
Posts: 153
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Thanks: 3
Thanked 10 Times in 6 Posts
(Thread Starter)
I had some runs this week, but didn't better the E.T. Top mph was 94.16. Anybody else been running so far?


@Grip-Grip I know you like to go to the track all the time. Any killer NOS times yet? Or times w/o NOS?
Idiot101 likes this.
UltSLK55 is offline  
#6 Old 02-19-2019
Registered Users
 
Join Date: Sep 2017
Location: Greenbrier, TN
Vehicle: 2007 SLK55
Other Toys: many
Posts: 124
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 38 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by UltSLK55 View Post
I had some runs this week, but didn't better the E.T. Top mph was 94.16. Anybody else been running so far?


@Grip-Grip I know you like to go to the track all the time. Any killer NOS times yet? Or times w/o NOS?
Nothing yet from me. I've been busy trying to get the fueling worked out along with some SC maintenance. I removed the supercharger last week and replaced the coupler and changed the fluid. After reinstalling on Sunday the car started acting crazy. It starts up and runs for a second or two at 2K RPM's, then just abruptly shuts down. Does it every time. Hopefully I get it figured out soon or I'll need to pull the SC again.

Nice 7.7 on street tires BTW.

By the way, do you run a wideband with AF gauge? Just curious what your AF looks like running Anthony's tune.
Idiot101 likes this.
Grip-Grip is offline  
#7 Old 02-19-2019
Registered Users
 
Join Date: Mar 2017
Location: TN
Vehicle: Supercharged 2005 SLK55
Posts: 153
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Thanks: 3
Thanked 10 Times in 6 Posts
(Thread Starter)
Quote:
Originally Posted by Grip-Grip View Post
Nothing yet from me. I've been busy trying to get the fueling worked out along with some SC maintenance. I removed the supercharger last week and replaced the coupler and changed the fluid. After reinstalling on Sunday the car started acting crazy. It starts up and runs for a second or two at 2K RPM's, then just abruptly shuts down. Does it every time. Hopefully I get it figured out soon or I'll need to pull the SC again.

Nice 7.7 on street tires BTW.

By the way, do you run a wideband with AF gauge? Just curious what your AF looks like running Anthony's tune.

I'm not running a wideband. It's 11.0 - 11.5 throughout based on dyno runs, but I don't have anything from the street - I have the torque app and an OBD2 reader but the output is garbage.
UltSLK55 is offline  
#8 Old 2 Weeks Ago
Registered Users
 
Join Date: Sep 2017
Location: Greenbrier, TN
Vehicle: 2007 SLK55
Other Toys: many
Posts: 124
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 38 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
The car is still running fat down low and lean up top, which I hope I'll resolve with the BEGI fuel pressure regulator when it arrives. Ordered it almost two weeks ago and no response from the vendor. Getting pissed.

Anyway, even with issues I decided to take it to the 1/8 mile today for some shake down runs. Both runs were problematic to say the least, but decent enough for a baseline.

Run one started out with over 120F+ IAT's, blew the tires off on the launch and got a little sideways (1.83 sec 60 ft), hit limp mode at around 85 MPH, then coasted to a 7.89 @ 79.66.

Run two started out with high IAT's again, blew the tires off again even with only 14PSI in the drag radials, got squirrely again (1.86 sec 60 ft), short shifted each gear to avoid limp mode and still did a 7.78 @ 93.15. Not bad for a junk run with a junk tune.

Once the AF is dialed in and I have a few more runs to figure out optimal tire pressure and launch RPM's the ET's should drop some. Hopefully I can get it down to low 7.6's or high 7.5's before it's too hot to run. My tuner gets back from vacation in two weeks, so at that point I'll be making a trip down to ATL to hopefully have it fine-tuned.

I won't be messing with nitrous until fall, and all I plan to run is a 50 shot at first so I won't have to retard the timing.











jet_fl and HawkX66 like this.

Last edited by Grip-Grip; 1 Week Ago at 04:47 PM.
Grip-Grip is offline  
#9 Old 1 Week Ago
Registered Users
 
Join Date: Sep 2017
Location: Greenbrier, TN
Vehicle: 2007 SLK55
Other Toys: many
Posts: 124
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 38 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
My SLK was making lots of power tonight, but the transmission was shifting terribly and killing all the fun. Huge delays between each shift became standard which obviously killed my ET's and trap speeds. I think I'm running too much or too little resistance on my MAF and hopefully I'll get it figured out soon along with the AF's.

Well, before you start saying excuses, excuses, read on a little more.

I couldn't get it to shift properly even when manually shifting tonight, but I think I made a little headway on the launch. So far my launches have been mediocre at best, and I knew there was so much more left on the table. So tonight I tried a different technique after doing a lot of head scratching and research and I think it paid off. How's a 1.59 and 1.61 sixty footer sound to you guys? At least that's one less thing to figure out.

Once the AF and transmission stop working against me I think my SLK is going to be a beast.

@UltSLK55 any updated ET's? Every time I take a step forward it seems I'm two steps back. Hope you're doing better.














UltSLK55 likes this.

Last edited by Grip-Grip; 1 Week Ago at 10:29 AM.
Grip-Grip is offline  
#10 Old 2 Days Ago
Registered Users
 
Join Date: Mar 2017
Location: TN
Vehicle: Supercharged 2005 SLK55
Posts: 153
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Thanks: 3
Thanked 10 Times in 6 Posts
(Thread Starter)
Quote:
Originally Posted by Grip-Grip View Post
How's a 1.59 and 1.61 sixty footer sound to you guys? At least that's one less thing to figure out.

Once the AF and transmission stop working against me I think my SLK is going to be a beast.

@UltSLK55 any updated ET's? Every time I take a step forward it seems I'm two steps back. Hope you're doing better.

I guess I didn't have a subscription on this thread, so didn't see that another post had been made. I haven't been back to the track since the first week and the follow up (which had a better trap but not ET). I think it can do better than the 1.77 60-ft on the Michelins, although I haven't done it yet.



A 1.59 60-ft on DRs is pretty sweet. It's too bad that you're having some issues with the tranny, where your ET didn't move much. Looks like my 7.700 on street tires still leads


I'm about to sell my car, I sent you a pm if you want some extra boost.
UltSLK55 is offline  
#11 Old 2 Days Ago
Registered Users
 
Join Date: Sep 2017
Location: Greenbrier, TN
Vehicle: 2007 SLK55
Other Toys: many
Posts: 124
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 38 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by UltSLK55 View Post
I guess I didn't have a subscription on this thread, so didn't see that another post had been made. I haven't been back to the track since the first week and the follow up (which had a better trap but not ET). I think it can do better than the 1.77 60-ft on the Michelins, although I haven't done it yet.



A 1.59 60-ft on DRs is pretty sweet. It's too bad that you're having some issues with the tranny, where your ET didn't move much. Looks like my 7.700 on street tires still leads


I'm about to sell my car, I sent you a pm if you want some extra boost.

You're the king for now, but I think after I replace the conductor plate in the transmission I'll get down where you left off.
Idiot101 likes this.
Grip-Grip is offline  
#12 Old 1 Day Ago
Registered Users
 
Join Date: Sep 2017
Location: Orlando
Vehicle: 05 SLK55 & 06 Kleemann 55K S8
Other Toys: 335Xi (modded) Suzuki GSXR1000
Posts: 509
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 154 Post(s)
Thanks: 4
Thanked 45 Times in 45 Posts
I am getting my new tires on tomorrow as long as they can promise not to scratch my wheels, will try to get back to the track after that. I have the process figured out to get it to shift correctly, let it shift to 2nd and 3rd and I have to manually shift after that. It will still bounce off the rev limiter in 3rd if I just leave it in auto mode.
Idiot101 likes this.
jet_fl is offline  
#13 Old 1 Day Ago
Registered Users
 
Join Date: Sep 2017
Location: Greenbrier, TN
Vehicle: 2007 SLK55
Other Toys: many
Posts: 124
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 38 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jet_fl View Post
I am getting my new tires on tomorrow as long as they can promise not to scratch my wheels, will try to get back to the track after that. I have the process figured out to get it to shift correctly, let it shift to 2nd and 3rd and I have to manually shift after that. It will still bounce off the rev limiter in 3rd if I just leave it in auto mode.

Mine is acting in a similar way. Have you considered changing out the transmission conductor plate?
Grip-Grip is offline  
#14 Old 20 Hours Ago
Registered Users
 
Join Date: Sep 2017
Location: Orlando
Vehicle: 05 SLK55 & 06 Kleemann 55K S8
Other Toys: 335Xi (modded) Suzuki GSXR1000
Posts: 509
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 154 Post(s)
Thanks: 4
Thanked 45 Times in 45 Posts
Quote:
Originally Posted by Grip-Grip View Post
Mine is acting in a similar way. Have you considered changing out the transmission conductor plate?
No, one wouldn't expect an issue with 13k miles on it... Let me know if that fixes yours though.
jet_fl is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > General Discussion about Mercedes Benz SLKs > Motorsports

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
HawkX66
User Tag List
Grip-Grip

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help removing SLK 350 instrument cluster undy SLK R171 General Discussion 21 11-14-2017 10:05 PM
Phil Lloyd new member Phil Lloyd New Members Introduce Yourself Here 19 04-29-2017 10:07 PM
U.S. auto industry quality slips for first time in 16 years: survey jbanks15 Off Topic 0 02-12-2014 11:32 AM
Daylight Standard time starts Sunday Nov 3rd 2 am for those that participate. jbanks15 Off Topic 8 11-02-2013 01:51 PM
Been a long time - Finally sporty again! RacerCub68 General Discussion 10 06-14-2009 06:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.