Mercedes Benz SLK Forum - View Profile: robbiemarcelo

robbiemarcelo robbiemarcelo is offline

Registered Users

  About Me

  • About robbiemarcelo
    Vehicle:
    1997 slk230 Linarit Blue
    Location
    subic bay Freeport zone, Philippines
    Home Country or State Flags
    Philippine
    Interests
    golf
    Occupation
    Telecoms Consultant

  Statistics

Total Posts
Total Thanks
General Information
  • Last Activity: 3 Weeks Ago
  • Join Date: 02-16-2013
  • Referrals: 0

  Friends

Showing Friends 1 to 1 of 1
  • Bon
    • Bon
    • Registered Users
    • Bon is offline

  Mentions

No results to display...

  Thread Tags

No results to display...

  Quotes

02-26-2018
07:35 PM - robbiemarcelo quoted Amphigory in post Temperature Sensor or Fan Control Module?
Yes, sounds like the fan contr...
09-16-2017
09:55 AM - Avel Du quoted robbiemarcelo in post Vario Roof Troubleshooting Tree - R170 Courtesy of Leapyfish
Yup used it as a guide but no luck...
08:36 AM - robbiemarcelo quoted Avel Du in post Vario Roof Troubleshooting Tree - R170 Courtesy of Leapyfish
R170 encyclopedia: SLK-Class...
03-03-2015
06:18 AM - robbiemarcelo quoted johne in post HelP....My SLK 320 suddenly wont start
Yay finally got my toy bac...
02-10-2015
08:28 PM - robbiemarcelo quoted johne in post HelP....My SLK 320 suddenly wont start
My K-40 looked brandnew wi...
11-21-2014
11:05 AM - a1automobil quoted robbiemarcelo in post engine won't crank, Aux fan turns on - checked K40
PM'ed you the link. Please check y...
11-18-2014
06:43 AM - robbiemarcelo quoted a1automobil in post engine won't crank, Aux fan turns on - checked K40
PM'ed you the link. Please check...
06:35 AM - robbiemarcelo quoted jbanks15 in post engine won't crank, Aux fan turns on - checked K40
Hi Jeff, My profile is up to...
09-29-2014
10:05 AM - robbiemarcelo quoted 2000r170 in post engine won't crank, Aux fan turns on - checked K40
i think your on the right tr...
09-26-2014
11:01 PM - robbiemarcelo quoted mrsamram in post K40 relay module
Update: Tried starting her ...
10:38 PM - robbiemarcelo quoted jbanks15 in post engine won't crank, Aux fan turns on - checked K40
You did not mention condition...
 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.