Extra Gauges Using Torque and V1 Install (updated pics later in thread) - Mercedes Benz SLK Forum

General Modifications R170 Details that make your car different

 1Likes
  • 1 Post By uberpanzer
 
LinkBack Thread Tools
#1 Old 09-06-2017
Registered Users
 
uberpanzer's Avatar
 
Join Date: Sep 2017
Location: San Diego CA
Vehicle: '01 SLK 230
Other Toys: '73 450SL, e30 M3, e21 turbo track rat
Posts: 27
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Extra Gauges Using Torque and V1 Install (updated pics later in thread)

Hey all! So I hit the ground running, picked up the SLK on Sat night, starting installing items on Monday. Set-up my phone mount (not pleased with it, but works for now). Plugged in my OBDII-BlueTooth interface and set about getting the Torque app (Android) all dialed in for the SLK. I've created the below 'dashboard' for it, with some items that I think I'll want to see. Was really pleased that Boost was a default output of the OBDII on the car, as it looks like I may need to program that on the ScanGauge2 if I want to use that instead. Since this will be my daily, also wanted to have Instant MPG and Trip MPG (and its reset), as well as Intake Air Temp, Volts, and figured I would Volumetric Efficiency a try (may remove this, not sure it is doing me any good).

The V1 install was decently straightforward, tapped into the power feeds for the dome light. However I think it is a bit down on power on that circuit, since if I turn on the dome light, the V1 turns off and won't come back on until the dome light is back to off. Not sure if that is an issue with the circuit I tapped into, something with the dome light circuits as a whole, or some other weirdness going on. I'll get a pic of that install and the phone mount tomorrow in the light, although not sure I'll be able to really get the phone in the mount, since the phone it my camera. Anyway, here's a screen shot of the Torque set-up, as basic as it is, in case anyone is interested.





Attached Images
File Type: jpg Torque Screenshot 2.jpg (57.0 KB, 153 views)
Avel Du likes this.

Last edited by jbanks15; 09-09-2017 at 07:30 PM.
uberpanzer is offline  
Sponsored Links
Advertisement
 
#2 Old 09-06-2017
Registered Users
 
PaPa Bear's Avatar
 
Join Date: Aug 2017
Location: Central Victoria
Vehicle: 1999 SLK230
Other Toys: What ever i have in my hand at the time
Posts: 196
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Thanks: 3
Thanked 24 Times in 16 Posts
Garage
Interested in the voltage drop on the dome light as i was thinking of using that my self for a torque setup.

It may be cable size or fuse size that is causing the issue.

Like to hear how you go

Cheers
PaPa Bear is offline  
#3 Old 09-07-2017
Registered Users
 
uberpanzer's Avatar
 
Join Date: Sep 2017
Location: San Diego CA
Vehicle: '01 SLK 230
Other Toys: '73 450SL, e30 M3, e21 turbo track rat
Posts: 27
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Not sure it is fuse, at least not with the V1 portion of the set-up. I've been using the exact same set-up in a prior car, same fuse and wires (to the V1 module) with zero issues. It may be the fuse on the dome light circuit, haven't checked it's rating yet, but it hasn't blown since both will work individually, just not together.
uberpanzer is offline  
 
#4 Old 09-07-2017
Registered Users
 
PaPa Bear's Avatar
 
Join Date: Aug 2017
Location: Central Victoria
Vehicle: 1999 SLK230
Other Toys: What ever i have in my hand at the time
Posts: 196
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Thanks: 3
Thanked 24 Times in 16 Posts
Garage
Quote:
Originally Posted by uberpanzer View Post
Not sure it is fuse, at least not with the V1 portion of the set-up. I've been using the exact same set-up in a prior car, same fuse and wires (to the V1 module) with zero issues. It may be the fuse on the dome light circuit, haven't checked it's rating yet, but it hasn't blown since both will work individually, just not together.
So if you have done it before with same wire size i would be looking for a bad connection some were along the circuit. Sometimes just by unpluging and repluging in conections can wipe off any corrosion on the contacts. (That incudes pulling the fuse out and back in again)

Best of luck

Cheers
PaPa Bear is offline  
#5 Old 09-09-2017
Registered Users
 
uberpanzer's Avatar
 
Join Date: Sep 2017
Location: San Diego CA
Vehicle: '01 SLK 230
Other Toys: '73 450SL, e30 M3, e21 turbo track rat
Posts: 27
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
OK, got the pic with my last smart phone (still had charge in the battery, funny enough). The V1 portion is a bit hard to detail, without ripping into the dome light and garage door button module again. But this is VISUALLY the way it is set-up now.






I'm not happy with the angle that the phone sits at, but there is only so much I can do with that mount as it is designed to be used on a vent, not a cup holder rail like I have it. So I've ordered a mount specifically for the R170 that gets bolted in to the side of the center console stack and just above & out of the way of the glove box. I'll post pics of that once it arrives and I install it. And as much as I LOVE being able to see the OBDII stuff on my phone screen, I may just revert back to using the ScanGauge2 and use the phone for maps/Waze only. We'll see. I'm going to go out and play with the SC2 and see if it can read boost like I want, which will be the main issue. If I can't get boost on it, then I won't be using it.
uberpanzer is offline  
#6 Old 09-09-2017
Registered Users
 
PaPa Bear's Avatar
 
Join Date: Aug 2017
Location: Central Victoria
Vehicle: 1999 SLK230
Other Toys: What ever i have in my hand at the time
Posts: 196
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Thanks: 3
Thanked 24 Times in 16 Posts
Garage
So that is what the cup holder looks like

(We only have a tray )

Did you get the power to your V1 sorted and if so what was it ?

Cheers
PaPa Bear is offline  
#7 Old 09-10-2017
Registered Users
 
uberpanzer's Avatar
 
Join Date: Sep 2017
Location: San Diego CA
Vehicle: '01 SLK 230
Other Toys: '73 450SL, e30 M3, e21 turbo track rat
Posts: 27
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Haven't gotten it sorted yet. I was waiting until I needed to run something else (probably ScanGauge2 cable) before digging back into the 'headliner'. I'm sending the SC2 off this week to get upgraded (mines from 2009 and the boost feature was added in a firmware update later), so once it is back and I determine if it reads boost on our motors, I'll install it and sort out the V1 issues.
uberpanzer is offline  
#8 Old 09-10-2017
Registered Users
 
Join Date: Aug 2017
Location: Northumberland, England
Vehicle: 2003 SLK 200K
Posts: 303
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 75 Post(s)
Thanks: 75
Thanked 12 Times in 12 Posts
The dome light must be fed via the dimming circuit and not from battery +ve else it wouldn't dim! Maybe that explains the lower voltage?
Cheers Neil


Sent from my iPhone using Tapatalk
neileg is offline  
#9 Old 09-11-2017
Registered Users
 
PaPa Bear's Avatar
 
Join Date: Aug 2017
Location: Central Victoria
Vehicle: 1999 SLK230
Other Toys: What ever i have in my hand at the time
Posts: 196
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Thanks: 3
Thanked 24 Times in 16 Posts
Garage
Of course !! (palm plant )

I really need to get my head around these modern cars
PaPa Bear is offline  
#10 Old 09-19-2017
Premium Member
 
devilman9050's Avatar
 
Join Date: Sep 2016
Location: Leicester
Vehicle: 2003 SLK230
Other Toys: ML280, CBR600
Posts: 342
Country:
Chats: 0
Mentioned: 53 Post(s)
Tagged: 0 Thread(s)
Quoted: 137 Post(s)
Thanks: 13
Thanked 69 Times in 46 Posts
Garage
Sorry if this is a silly question folks, what's a V1?

I've got a bluetooth OBDII but have been using Track Addict (records video and overlays the OBDII info). Is the Torque app just called Torque on Google Play?

Thanks,

Dez

Fancy seeing what your SLK can do on the track, and getting a bit of hazardous driving training?

Come along to the track day at Rockingham on the 9th September 2018:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
devilman9050 is offline  
#11 Old 09-20-2017
Registered Users
 
uberpanzer's Avatar
 
Join Date: Sep 2017
Location: San Diego CA
Vehicle: '01 SLK 230
Other Toys: '73 450SL, e30 M3, e21 turbo track rat
Posts: 27
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Quote:
Originally Posted by devilman9050 View Post
Sorry if this is a silly question folks, what's a V1?

I've got a bluetooth OBDII but have been using Track Addict (records video and overlays the OBDII info). Is the Torque app just called Torque on Google Play?
Dez - Not a silly question at all. V1 is a Valentine1 radar detector. The one with the arrows to point out the direction of the radar, as well as a counter so you know how many sources it is picking up (as well as the radar band they are using and Laser detection). With the speeds I tend to drive cars at, it is a must (even in the Smart that was my previous daily driver).

As for the app, yes it is just called Torque on the Play Store. There is a Pro and a Lite version, with Pro being ad-free (worth it if you use it a lot, and price is low anyway). The app author is Ian Hawkins, to help you ensure you're looking at the right one. I've heard decent things about Track Addict from some friends who track their cars a lot, but as my phone is usually not mounted in a way to get footage out the windshield, it hasn't been something I've thought about picking up. That, and I am not going back to the track for a while after having punched a rod through the side of the block on my 'fun car' the last time I went. I need to have more cash sitting around before I do that again.
uberpanzer is offline  
#12 Old 09-20-2017
Premium Member

 
Turdo2's Avatar
 
Join Date: Apr 2013
Location: Kansas
Vehicle: 1999 SLK 5.4 M113 V8
Other Toys: Ram 2500, Plymouth Duster
Posts: 1,298
Country:
Chats: 0
Mentioned: 376 Post(s)
Tagged: 1 Thread(s)
Quoted: 346 Post(s)
Thanks: 0
Thanked 76 Times in 68 Posts
Garage
has that radar detector actually worked?

side note: You actually found a good use for those cup holders!!!
Turdo2 is offline  
#13 Old 09-21-2017
Registered Users
 
DreamerGr's Avatar
 
Join Date: Mar 2017
Location: Athens Greece
Vehicle: SLK 200 R170 2000 192Bhp
Other Toys: MG Tf , a 18ft 120hp Mercury speedboat
Posts: 22
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 7
Thanked 1 Time in 1 Post
Garage
Is there any way to do this mod on the OLD OBD ?
I got an extension cord from old OBD to new one but it wont work for me. Maybe its faulty or something.
DreamerGr is offline  
#14 Old 09-21-2017
Premium Member
 
savcom's Avatar
 
Join Date: Nov 2015
Location: Wiltshire, UK
Vehicle: 2002 Blue SLK320 known as 'Silkie"
Other Toys: 2010 Grey BMW F10 528i
Posts: 2,523
Country:
Chats: 0
Mentioned: 462 Post(s)
Tagged: 0 Thread(s)
Quoted: 604 Post(s)
Thanks: 163
Thanked 293 Times in 237 Posts
Garage
Send a message via Skype™ to savcom
Chaps

Sorry if I'm late to the party but there is a permanent +12V available in the dome light - I know because I feed my dashcam from this location.

See my posts on fitting LED dome lamps and fitting the dashcam.

Circuit for facelift R170's attached too.

Dome Wiring.jpg

Hope these help

Now : Silkie - 2002 Lazulithe Blue Mercedes Benz SLK320
Also
: 2011 Sophisto Grey BMW F10 528i SE


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Brings a smile to my face whenever I drive her



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Previous :
1965 Triumph Herald 12/50 ... 1972 Austin 1300 ... 1982 Volvo 265GLE ...

1987 Volkswagen Caravelle ... 1997 Rover 214si ... 2002 BMW E39 530D

If I've helped you sort your problem(s) out, click the 'Thanks' button on the right hand side under my signature.
savcom is offline  
#15 Old 09-22-2017
Registered Users
 
uberpanzer's Avatar
 
Join Date: Sep 2017
Location: San Diego CA
Vehicle: '01 SLK 230
Other Toys: '73 450SL, e30 M3, e21 turbo track rat
Posts: 27
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Quote:
Originally Posted by DreamerGr View Post
Is there any way to do this mod on the OLD OBD ?
I got an extension cord from old OBD to new one but it wont work for me. Maybe its faulty or something.
I'm not sure what you mean by "old OBD" here, but I am new to newer MB cars. Being that my car is US-spec, it has OBDII, as mandated by the government here. A lot of auto makers in the world used that standard in all their markets as well, cutting down on having to have different interfaces for different markets, but I'm not sure if MB did this, especially on the the R170. What you're looking for is the port like this under the dash by the hood release:

uberpanzer is offline  
#16 Old 09-22-2017
Registered Users
 
uberpanzer's Avatar
 
Join Date: Sep 2017
Location: San Diego CA
Vehicle: '01 SLK 230
Other Toys: '73 450SL, e30 M3, e21 turbo track rat
Posts: 27
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Quote:
Originally Posted by savcom View Post
Hope these help
This is the best kind of late, exactly what I needed to know about the wires at the dome light 'harness' in your dash cam thread! I don't think I used that same positive wire, and that might be my problem. I'll check into that when I find the time and see if it doesn't resolve the issue. THANKS!!!!!!!
uberpanzer is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > General Modifications R170

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.