Indicator & reverse lights problem - Mercedes Benz SLK Forum

General Modifications R170 Details that make your car different

 
LinkBack Thread Tools
#1 Old 06-17-2016
Registered Users
 
Join Date: Jun 2014
Location: Ireland
Vehicle: 2003 60,000 miles R170 200
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 0
Thanked 7 Times in 4 Posts
(Thread Starter)
Indicator & reverse lights problem

I had intermittent indicator & reverse light failure which I eventually tracked down to the harness plug in the console fuse box- part number 2105455728 - picture attached.

This isn't making good contact when it's plugged into it's harness as when I shift it the indicator lights work but when I release it they go off. I'm hoping that it's the plug itself & not any electrical connection inside the fuse box (a broken solder joint, for instance).

This plug has two connections. When I look inside this plug, I can just about see that there are spring splines that should press against the two prongs in the harness to make a good electrical connection. I feel that these splines have splayed & no longer press against the prongs when the plug is seated.

I would like to try to pull these two wires & their connectors out of the plug in order to fix the spring contacts but can't seem to achieve this. Like other plugs of this type, I believe the wire & connector slide into it's plug & snap into place with a stop that prevents it from being pulled back out. Normally to release the wire+connector the stop tab is pushed in & the wire+connector pulled out but I can't seem to find what is pushed in & I don't want to break the plug.

Any help appreciated
Attached Images
File Type: jpg IMG_20160617_181038.jpg (31.0 KB, 6 views)
File Type: jpg IMG_20160617_181021.jpg (32.2 KB, 5 views)
File Type: jpg IMG_20160617_180958.jpg (32.9 KB, 6 views)
dweeb4 is offline  
Sponsored Links
Advertisement
 
#2 Old 06-17-2016
Registered Users
 
Join Date: Jun 2014
Location: Ireland
Vehicle: 2003 60,000 miles R170 200
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 0
Thanked 7 Times in 4 Posts
(Thread Starter)
Just to explain the pics:
- The first one is this two wire plug in my hand. There are two metal parts of the wire connector exposed & I suspect that this is what should be pushed in to release the connector & allow it to be pulled out of the back of the plug? Can anyone confirm this as I haven't used too much force on it for fear of breaking something

- the second pic is where the plug is plugged into the fuse box
- the third pic shows the side & back of the fuse box itself
dweeb4 is offline  
#3 Old 06-17-2016
Registered Users
 
Join Date: Jun 2014
Location: Ireland
Vehicle: 2003 60,000 miles R170 200
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 0
Thanked 7 Times in 4 Posts
(Thread Starter)
Update:
To test if it was the plug, I cut off the plug & connected the wires directly to the harness

Turns out it's not the plug - it's some internal connection in the fuse box - ****!!!

Anybody know how to open this fuse box?

If it's a solder joint, I can fix it rather than spending 100s of Euros on a fusebox!!
dweeb4 is offline  
 
#4 Old 06-17-2016
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,213
Country:
Chats: 0
Mentioned: 554 Post(s)
Tagged: 0 Thread(s)
Quoted: 877 Post(s)
Thanks: 155
Thanked 507 Times in 468 Posts
I don't recall anybody here disassembling and repairing the light module. If its like the other modules a re-flow of the solder joints may help. If you do disassemble it, please post some photos!
efair is online now  
#5 Old 06-17-2016
Registered Users
 
Join Date: Jun 2014
Location: Ireland
Vehicle: 2003 60,000 miles R170 200
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 0
Thanked 7 Times in 4 Posts
(Thread Starter)
Quote:
Originally Posted by efair View Post
I don't recall anybody here disassembling and repairing the light module. If its like the other modules a re-flow of the solder joints may help. If you do disassemble it, please post some photos!
Thanks efair - probably a step too far for most but this is such a small problem that it seems a shame not to have a go at opening it up - I'm pretty sure that it is a solder joint breakage so easy enough to fix - if I can get into it.

Is there an exploded view of this part anywhere to be found - that would help the disassembly?
dweeb4 is offline  
#6 Old 06-17-2016
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 90,485
Country:
Chats: 38
Mentioned: 445 Post(s)
Tagged: 5 Thread(s)
Quoted: 6450 Post(s)
Thanks: 3,218
Thanked 10,968 Times in 8,332 Posts
you could look here maybe

BBB Industries - TSB's & Wiring Diagrams - End User License Agreement


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#7 Old 06-17-2016
Registered Users
 
Join Date: Jun 2014
Location: Ireland
Vehicle: 2003 60,000 miles R170 200
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 0
Thanked 7 Times in 4 Posts
(Thread Starter)
Quote:
Originally Posted by jbanks15 View Post
Thanks but didn't find an exploded view of the part i.e a mechanical drawing rather than an electrical diagram
dweeb4 is offline  
#8 Old 06-17-2016
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,213
Country:
Chats: 0
Mentioned: 554 Post(s)
Tagged: 0 Thread(s)
Quoted: 877 Post(s)
Thanks: 155
Thanked 507 Times in 468 Posts
I've never seen one - or even photos of the insides of one. But - maybe I've missed it.
efair is online now  
#9 Old 06-18-2016
Registered Users
 
Join Date: Jun 2014
Location: Ireland
Vehicle: 2003 60,000 miles R170 200
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 0
Thanked 7 Times in 4 Posts
(Thread Starter)
OK, made some progress but this is turning out to be a bigger job than I anticipated - don't they always?

Pics attached of various stages of stripping down the lights fuse box & more to come (which will shock you at the bad level of workmanship in this part)

First pic shows the first stage in disassembling the unit - first step is to remove the lights knob which you can see on the right of the pic - this has four clear plastic clips, two of which hold it onto the white central stalk (you can't see this in the pic on the right as the casing is partially removed).

Second pic shows fuse cover removed (you can see the white stalk on the right now). The panel where the fuses are plugged in is at the bottom of the pic & this is the area where my problem is - the indicator lights fuse socket isn't making a good electrical connection

Third pic shows this fuse panel - the problem socket is the one on the bottom right of the pic. Looking in from the side, under this panel I could see that the metal stub from the fuse socket leg closest to the edge was not properly soldered into the green underlying pcb (this is a flexible pcb that wraps around 3 sides of the fuse case). Looking at the other fuse socket stubs also showed that there was very little solder holding them onto the pcb.

I was able to prise the fuse socket panel off the pcb (it had to be released by two clips at either end). It shouldn't be possible to release this panel if all fuse sockets were properly soldered onto the underlying pcb - really shockingly bad workmanship. Fixing this is going to be a problem - I'm going to have to unsolder all the joints seen in pic 2 so I can peel back the pcb & solder the fuse socket tabs from the underside of the pcb - there's no other way to do this
Attached Images
File Type: jpg IMG_20160618_102130.jpg (46.2 KB, 2 views)
File Type: jpg IMG_20160618_102209.jpg (48.9 KB, 2 views)
File Type: jpg IMG_20160618_105429.jpg (43.6 KB, 2 views)

Last edited by dweeb4; 06-18-2016 at 06:59 PM.
dweeb4 is offline  
The Following User Says Thank You to dweeb4 For This Useful Post:
#10 Old 06-22-2016
Registered Users
 
Join Date: Jun 2014
Location: Ireland
Vehicle: 2003 60,000 miles R170 200
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 0
Thanked 7 Times in 4 Posts
(Thread Starter)
Job done!
It didn't take me 3 days I just had to leave it aside while I attended to other life issues.

The problem was as I had diagnosed it - real shoddy workmanship on the fuse holders connection to the underlying PCB - actually little to no solder used for this electrical connection.

Some pics to show what I'm talking about & how I fixed it

First pic is the underlying pcb with the black plastic fuse holder & fuses taken off - this fuse holder shouldn't be removable - each fuse should be firmly soldered to the underlying pcb. As can be seen in this pic very little solder used on each hole where the fuse tab should be soldered (I have soldered in the first 3 fuse holder tabs in the top right). I would imagine that there were further problems going to show up down the line because of this original shoddy soldering - other fuse holders may have become more loose & dropped electrical connection like the indicator lights fuse!

Second pic is how I approached the fix - I decided to remove each fuse socket from its holder in the black plastic fuse panel & soldered it directly onto the pcb before pushing the fuse panel back on. Each fuse holder slots into a tight hole in this fuse panel so aligning the fuse sockets in the pcb is critical. You can get away with some misalignment as can be seen in this pic

Anyway, it's all back together now & working fine

Hope this is of help to someone - I saved myself €500 - cost of this new box from Mercedes (or €120 if bought off ebay 2nd hand)
Attached Images
File Type: jpg IMG_20160622_130624.jpg (24.0 KB, 6 views)
File Type: jpg IMG_20160622_140524.jpg (24.1 KB, 5 views)
dweeb4 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > General Modifications R170

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
do the led taillights cause bulb out errors? miguelaca General Modifications R171 210 07-13-2016 10:33 AM
New Spyder Lights/Repair Bumper/Marker Lights Philo SLK R170 class DIY 11 03-03-2015 12:37 AM
How to have the main lights + the LED lights on at the same time? addictive SLK R172 General Discussion 7 08-09-2012 05:29 AM
2001 SLK320 6 spd manual transmission problem CO-SLK320 SLK R170 General Discussion 0 10-11-2010 01:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.