Smarttop oops - Mercedes Benz SLK Forum

General Discussion Topics must pertain to all 3 generations of SLK - R170, R171 and R172

 1Likes
  • 1 Post By mr-lama
 
LinkBack Thread Tools
#1 Old 06-11-2012
Registered Users
 
Join Date: Jan 2012
Location: South korea
Vehicle: 2006 slk55 AMG
Posts: 51
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 11 Times in 3 Posts
(Thread Starter)
Smarttop oops

Ok, put in my smarttop and wired in the valentine one detector today. It sucked, I hate working with plastic pieces and it seems like everything is designed to cut you, but after a while I got it, and I do love it, it works great.

However, during the process I did something that made my car think there is a SRS error. I did a search and found someone who did the same thing, he got his reset by some expert mercedes technician. Sounds like mine needs the same thing. I am not really sure about bringing it by mercedes, don't know what they will do or if they will dig around and find the smarttop. Went by another place and their little handheld computer wouldn't reset it, and they said it would be $50 to hook it up to their other thing they use to diagnose cars, and they could do it with that.


Any recommendations on what I should do? Would unplugging the battery for a while do any good for me? Do you think mercedes could do anything, hopefully without spending a bunch of money? I don't really want to buy my own code reader to reset it, I don't work on the car myself enough to warrant the money.

This smarttop is cool though. Didn't realize how much of a pain it was to hold that button. Now if I can just get this fixed it will be perfect!
mr-lama is offline  
Sponsored Links
Advertisement
 
#2 Old 06-11-2012
Registered Users
 
Join Date: Dec 2011
Location: Sofia, Bulgaria
Vehicle: SLK R171 200k 2005
Posts: 287
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 105
Thanked 58 Times in 32 Posts
Garage
I think that you could find an indy garage where they will manage to reset the error... Even here we have such garages...
SamuraiSpirit is offline  
#3 Old 06-11-2012
Founding Member #2

 
etyu's Avatar
 
Join Date: Jun 2006
Location: Orange County, CA
Vehicle: 2008 SLK 55
Posts: 19,391
Country:
Chats: 11
Mentioned: 80 Post(s)
Tagged: 0 Thread(s)
Quoted: 345 Post(s)
Thanks: 4,571
Thanked 3,142 Times in 2,269 Posts
Garage
Double check the wiring harness and connectors at the bottom of the seats to make sure they are well seated or connected tight and proper. Use a flashlight/torch as needed.

Make sure you "de-activate" the smartTOP (Function 1 is OFF ) before going to any garage/shop, otherwise you DAS will get error message.

Eddy



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Pewter(cubanitsilber metallic)/Beige, PIII package, Airscarf, Hands-Free Communication System, Lighting package; Designo Black Leather Cover on e-brake handle(Thank you Bill T), SmartTop v3.x, John's 3BFM, M113 AMG OEM air filters, Modified R170 ant., clear side-markers & front parking lamps w/error-free LEDs, chromed front & rear turn indicator lamps, steel mesh at battery bay cover & cabin air intake, sock-over-seatbelt buckles, belt-loop guide protectors, Lamin-X fog lamp protectors, bilateral rear fog lamps enabled, AMG crest on gear shift knob
etyu is offline  
 
#4 Old 06-12-2012
Registered Users
 
Join Date: Jan 2012
Location: South korea
Vehicle: 2006 slk55 AMG
Posts: 51
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 11 Times in 3 Posts
(Thread Starter)
Ok, went to a local independent shop and they reset it for me. All is good, no issues.

Just to check, the srs light stays on for a split second after startup, then goes away. Is that normal? No error warnings or anything, just don't remember if it has always done that or not.

Thanks guy!!
SamuraiSpirit likes this.
mr-lama is offline  
#5 Old 06-12-2012
Sadly Woolly has passed away

 
Woolly's Avatar
 
Join Date: Jun 2006
Location: Co. Durham, UK
Vehicle: SLK350 MT
Other Toys: CLK 270CDI (Slushbox!!)
Posts: 17,375
Country:
Chats: 1297
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Thanks: 2,912
Thanked 3,515 Times in 2,416 Posts
Garage
Quote:
Originally Posted by mr-lama View Post
Just to check, the srs light stays on for a split second after startup, then goes away. Is that normal? No error warnings or anything, just don't remember if it has always done that or not.

Thanks guy!!
It's normal for it to stay on for about a second on startup.






To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

MB SLK 350 Andradite Green (6 speed manual)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Woolly is offline  
#6 Old 06-12-2012
Founding Member #2

 
etyu's Avatar
 
Join Date: Jun 2006
Location: Orange County, CA
Vehicle: 2008 SLK 55
Posts: 19,391
Country:
Chats: 11
Mentioned: 80 Post(s)
Tagged: 0 Thread(s)
Quoted: 345 Post(s)
Thanks: 4,571
Thanked 3,142 Times in 2,269 Posts
Garage
Quote:
Originally Posted by mr-lama View Post
Ok, went to a local independent shop and they reset it for me. All is good, no issues.

Just to check, the srs light stays on for a split second after startup, then goes away. Is that normal? No error warnings or anything, just don't remember if it has always done that or not.

Thanks guy!!
Per DansSLK, when doing the ignition process to start the R171, do the following:

1. insert key and turn to position 1, the SRS red warning lamp will turn on (brake warning lamp will also turn on if e-brake is engaged), wait for SRS lamp to turn off (usually after 5 seconds, this is when the car computer system is doing its checks and boot-up process), then ....

2. turn key to position 2, and wait 3 seconds, then ....

3. turn key to the right and release immediately (think of it as a spring-loaded switch, this sends signal to start ignition process and start the engine). Do not turn and hold (as this will send multiple signals to start the engine, may confuse the "car-puter", much like a keyboard sends a signal to type a letter)

.... so to answer your question: yes, it is normal for SRS to light up for a few seconds while in position 1.

Eddy



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Pewter(cubanitsilber metallic)/Beige, PIII package, Airscarf, Hands-Free Communication System, Lighting package; Designo Black Leather Cover on e-brake handle(Thank you Bill T), SmartTop v3.x, John's 3BFM, M113 AMG OEM air filters, Modified R170 ant., clear side-markers & front parking lamps w/error-free LEDs, chromed front & rear turn indicator lamps, steel mesh at battery bay cover & cabin air intake, sock-over-seatbelt buckles, belt-loop guide protectors, Lamin-X fog lamp protectors, bilateral rear fog lamps enabled, AMG crest on gear shift knob
etyu is offline  
The Following User Says Thank You to etyu For This Useful Post:
#7 Old 06-12-2012
Registered Users
 
Join Date: Jan 2012
Location: South korea
Vehicle: 2006 slk55 AMG
Posts: 51
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 11 Times in 3 Posts
(Thread Starter)
Sweet.
mr-lama is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > General Discussion about Mercedes Benz SLKs > General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Original Issue Piecha module vs SmartTop, personal impressions etyu General Modifications R171 41 11-14-2013 12:19 PM
SmartKey/Cartronics/Mid City, and SmartTop danieleik General Discussion 26 09-11-2013 08:59 AM
Problem installing SmartTop module Karl-Johan SLK R171 General Discussion 7 06-10-2012 05:57 PM
Faulty SmartTop? etyu General Discussion 3 08-21-2011 06:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.