Throttle and gas pedal synchronisation?? - Mercedes Benz SLK Forum

General Discussion Topics must pertain to all 3 generations of SLK - R170, R171 and R172

 
LinkBack Thread Tools
#1 Old 09-16-2009
Registered Users
 
Join Date: Aug 2008
Location: Kuwait
Vehicle: E55 - 99' ... SLK55 - 06' ... C63 - 09'
Other Toys: S65 - 05'
Posts: 82
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
(Thread Starter)
Throttle and gas pedal synchronisation??

Hello guys,

I've driven a Merc since almost the first day i started driving. That's about 6/7 yrs now. So i guess i can say i'm pretty experienced with the know hows of our cars be it an E class, C, S or SLK regarding mechanics of the car, service etc.

I dropped my SLK the other day at the stealership to get the fuel pump replaced. I've had to wait a week for the fuel pump to be back ordered from Germany. Good news its finally arrived and installed. But when i called the stealers today to see if i can come pick up the car they said that they are still working on synchronising the gas pedal with the throttle. To be honest its the first time i hear of such a thing. He mentioned that the fuel pump is ok and that the car starts properly, but once you step on the pedal there is no response and that is why it needs to be synched with the throttle. Does anybody know any information about this? How does it work and how long does it take to "synchronise" or program or whatever? I'm really worried. It's been about 4 hrs since i talked to him. I dont think it should take that long. I even told him to do whatever he wanted just dont touch the ECU as its not stock. He replied that he wouldnt be touching the ECU but something else... MU or something like. Can't wait to get my baby back.

Appreciate if anybody here knows anything about this.
mr.flyer is offline  
Sponsored Links
Advertisement
 
#2 Old 09-16-2009
Registered Users
 
Join Date: Jul 2007
Location: Australia, Perth
Vehicle: 07 SLK200K
Other Toys: Ducati 848
Posts: 820
Country:
Chats: 1189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 42
Thanked 72 Times in 54 Posts
Cant help you but I hope it works out.

ps. nice collection of cars you got there
RaihaX is offline  
#3 Old 09-16-2009
Registered Users
 
GeeJay's Avatar
 
Join Date: Jan 2009
Location: North-West Blighty.....
Vehicle: '16 C250d AMG Estate Premium+ Designo Hyacinth Metalic
Other Toys: Guitars... :-) Formerly '08 SLK200 6sp Palladium
Posts: 5,134
Country:
Chats: 91
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
Thanks: 652
Thanked 793 Times in 574 Posts
Like most/many modern cars, the SLK is 'drive-by-wire'. You put your foot on the accelerator pedal which provides an electrical signal and an ECU then calculates how much the throttle angle should be applied to meet your demands. It shouldn't take long to fix the issue though, but it may have gone into a limp-home mode for some reason. The dealer will just have to work through diagnostic procedures and sort it out.

Good luck, I hope they find the problem soon.
GeeJay is offline  
 
#4 Old 09-16-2009
Registered Users
 
Join Date: Aug 2008
Location: Kuwait
Vehicle: E55 - 99' ... SLK55 - 06' ... C63 - 09'
Other Toys: S65 - 05'
Posts: 82
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
(Thread Starter)
Ya it does kind of make sense regarding the fly by wire. Am just worried as to why its taking so long just to reprogramme limp mode. The service advisor said he'd call and update later but didny. He even refused to give me a time estimate. I'll pass them by 2moro and give them an a$$ whoopin'
mr.flyer is offline  
#5 Old 09-16-2009
aka John

 
UK-C200's Avatar
 
Join Date: May 2008
Location: Richmond, Tx
Vehicle: LHD Black SLK350, LHD Firemist SLK55
Other Toys: Nacra F18
Posts: 13,012
Country:
Chats: 1143
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Thanks: 1,712
Thanked 2,920 Times in 2,028 Posts
Best of luck - as far as I know, the throttle is directly controlled by the ECU, so I hope they don't flash it. WIS says to flash with the current (or updated) firmware as a first step.

Interestingly enough, there's nothing that indicates that the throttle would get "out of sync", but I really didn't do a lot of digging. Resetting "limp home" with DAS takes about 5 minutes unless there's an underlying problem that causes it to go "back" into limp home mode. Limp mode also does not impact the throttle to ECU systems, it's just the ECU/TCU saying "limit revs/ limit shifts".



UK-C200 is offline  
#6 Old 09-17-2009
Registered Users
 
Join Date: Aug 2008
Location: Kuwait
Vehicle: E55 - 99' ... SLK55 - 06' ... C63 - 09'
Other Toys: S65 - 05'
Posts: 82
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
(Thread Starter)
I CAN'T BELIEVE IT!! i got a call from the stealership today (after 2 days working on the "sync") and they told me that we can't fix it or figure it out because it's a "modified" car!! seriously WHAT THE ****!!! so what were you doing for the past 2 days!!.. and i cant do anything about it cuz there's a national holiday for a week where almost everything is closed.. i'm going crazy!!
mr.flyer is offline  
#7 Old 09-17-2009
aka John

 
UK-C200's Avatar
 
Join Date: May 2008
Location: Richmond, Tx
Vehicle: LHD Black SLK350, LHD Firemist SLK55
Other Toys: Nacra F18
Posts: 13,012
Country:
Chats: 1143
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Thanks: 1,712
Thanked 2,920 Times in 2,028 Posts
Quote:
Originally Posted by mr.flyer View Post
I CAN'T BELIEVE IT!! i got a call from the stealership today (after 2 days working on the "sync") and they told me that we can't fix it or figure it out because it's a "modified" car!! seriously WHAT THE ****!!! so what were you doing for the past 2 days!!.. and i cant do anything about it cuz there's a national holiday for a week where almost everything is closed.. i'm going crazy!!
See above - I can almost guarantee they keep getting back to the point in the system that says "flash ECU next" - and obviously don't want to toast your custom tune.



UK-C200 is offline  
#8 Old 09-17-2009
Premium Member
 
PropDr's Avatar
 
Join Date: Jun 2009
Location: Eugene,OR
Vehicle: 2008 SLK 55 AMG 030 with SC
Other Toys: 2012 Ford Raptor, 06 BMW R1200 RT
Posts: 3,248
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Thanks: 277
Thanked 622 Times in 455 Posts
Garage
There is just one point that I can’t comprehend: the relationship between replacing a fuel pump and the loss of communication between the gas pedal and the throttle actuation?
In my humble opinion: someone screwed up!


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

My Beautiful Black Walküre (Valkyrie)
PropDr is offline  
#9 Old 09-17-2009
Founding Member #2

 
etyu's Avatar
 
Join Date: Jun 2006
Location: Orange County, CA
Vehicle: 2008 SLK 55
Posts: 19,393
Country:
Chats: 11
Mentioned: 82 Post(s)
Tagged: 0 Thread(s)
Quoted: 345 Post(s)
Thanks: 4,571
Thanked 3,143 Times in 2,269 Posts
Garage
There may not be much choice but to "reboot" -- which means losing the custom ECU. Perhaps the tuner will reprogram the ECU after MB flashes the ECU and at least gets the vehicle running again, albeit not to your specifications.

I can understand that this is quite frustrating to say the least.

Eddy



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Pewter(cubanitsilber metallic)/Beige, PIII package, Airscarf, Hands-Free Communication System, Lighting package; Designo Black Leather Cover on e-brake handle(Thank you Bill T), SmartTop v3.x, John's 3BFM, M113 AMG OEM air filters, Modified R170 ant., clear side-markers & front parking lamps w/error-free LEDs, chromed front & rear turn indicator lamps, steel mesh at battery bay cover & cabin air intake, sock-over-seatbelt buckles, belt-loop guide protectors, Lamin-X fog lamp protectors, bilateral rear fog lamps enabled, AMG crest on gear shift knob
etyu is offline  
#10 Old 09-18-2009
Registered Users
 
Join Date: Aug 2008
Location: Kuwait
Vehicle: E55 - 99' ... SLK55 - 06' ... C63 - 09'
Other Toys: S65 - 05'
Posts: 82
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
(Thread Starter)
Its obvious that somebody screwed up.. they just don't want to admit it. What's getting on my nerves even more is the lack of communication from them and the stupid "customers not allowed in the garage" policy!! i mean what the hell?! i can't even see my own car. UK-C200 they wouldn't tell me what the problem is or what the error message was. They just said we can't touch it or fix it cuz it's "modified". I finally got to the point that if it needs having the ECu rebooted or set back to stock as a final attempt then just go ahead with it. He said he'd check with the service manager but i never heard from him again for the rest of the day. Now i'll have to wait a couple of days until this holiday is over.
mr.flyer is offline  
#11 Old 09-18-2009
aka John

 
UK-C200's Avatar
 
Join Date: May 2008
Location: Richmond, Tx
Vehicle: LHD Black SLK350, LHD Firemist SLK55
Other Toys: Nacra F18
Posts: 13,012
Country:
Chats: 1143
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Thanks: 1,712
Thanked 2,920 Times in 2,028 Posts
Flyer - understand your frustrations, and I have been down that road in the past when I was about the pull the trigger on a Kleemanized '55.

I talked with three dealers in my area, all of whom assured me I was going to be "on my own" every time I ended up with a problem. One of the SA's even went so far over coffee and smokes to tell me that "you will be screwed, MB will use your modifications to say "we can't fix it, it's your falut" every time they ran into a problem - so have deep pockets and an independent in mind". This is in the US, which does have some decent legal remedies in such situations. Needless to say, I chose not to go that route.

In the US and UK, there are very firm "work place safety" insurance issues that prevent a non-employee into the workshop areas.

Best of luck in getting your problem sorted - and in the US at least, Kleeman assured me that if the dealer ever erased/flashed my ECU they would re-program it for a nominal fee..



UK-C200 is offline  
#12 Old 09-18-2009
Registered Users
 
Join Date: Aug 2008
Location: Kuwait
Vehicle: E55 - 99' ... SLK55 - 06' ... C63 - 09'
Other Toys: S65 - 05'
Posts: 82
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
(Thread Starter)
I understand that they would be using the modification as an excuse to not fix a fault, but i didnt expect them to be so anal about it. Especially considering i was a VERY regular customer at the service garage having currently own 4 AMG cars. As for having the ECU retuned i can always send it back to US but i wanted to avoid that step AGAIN. I guess i'll just have to tell them to flash it back to stock and take it from there. But i'm actually even having thoughts that they don't even know how to flash!! .. seriously if the service center was even ok here i would't be complaining.. but they are crap... now only "problem" is that the nearest authorized Kleemann workshop is in Dubai.. some 800 miles
mr.flyer is offline  
#13 Old 09-18-2009
Registered Users
 
Join Date: Dec 2008
Location: USA
Vehicle: 2009 SLK 350 Sport Motor
Other Toys: 2008 C300
Posts: 1,495
Country:
Chats: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 217
Thanked 156 Times in 122 Posts
Makes you wonder what the excuse would be, if the car was still stock.
mb911 is offline  
#14 Old 09-18-2009
aka John

 
UK-C200's Avatar
 
Join Date: May 2008
Location: Richmond, Tx
Vehicle: LHD Black SLK350, LHD Firemist SLK55
Other Toys: Nacra F18
Posts: 13,012
Country:
Chats: 1143
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Thanks: 1,712
Thanked 2,920 Times in 2,028 Posts
Well, flashing the ECU is pretty much plug and play - DAS and click ok about 10 times, so hopefully they can manage that, and even more importantly, hopefully it puts right whatever has gone wrong!

I really don't understand some MB dealers these days - seems like the "quality" aspect has gone away. My grandfather owned the first Benz in our family, and he held on to it for over 20 years, and didn't own any other brand after that first one. Times have changed, but so far I've been treated well, and while I've not held on to one of my MB's for 20 years, I'm on my 5th one - only the one AMG, but I think I'll own another at some point in time!



UK-C200 is offline  
#15 Old 09-19-2009
DansSlk
Guest
 
Posts: n/a
Chats:
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
I know i'm a bit late but i totally agree on the screw-up, throttle calibration is automatic (with factory firmware of course) and the fuel pump has no data connection to the ECU, it just turns it on and off so no 'sync'.
The Following User Says Thank You to For This Useful Post:
#16 Old 09-20-2009
Registered Users
 
Join Date: Aug 2008
Location: Kuwait
Vehicle: E55 - 99' ... SLK55 - 06' ... C63 - 09'
Other Toys: S65 - 05'
Posts: 82
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
(Thread Starter)
Dan, by factory firmware you referring to the ECU? if its set back to stock would it automatically calibrate the throttle? Ya i'm pretty sure all of this has nothing to do with the pump being changed. Something must've gone wrong somewhere along the line.. it's just that thats what it started as...
mr.flyer is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > General Discussion about Mercedes Benz SLKs > General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Double Clutching MCFaisal General Discussion 33 05-25-2007 11:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.