Fault codes ESP and Transmission, SLK R171 limp mode - Mercedes Benz SLK Forum

DAS/STAR Coding Any links or post’s leading to pirated software will be immediately deleted. SLKWORLD is not responsible for any damage caused by miscoding, use at your own risk.

 1Likes
  • 1 Post By Avel Du
 
LinkBack Thread Tools
#1 Old 04-12-2019
Registered Users
 
vennarenate's Avatar
 
Join Date: Apr 2016
Location: Rotterdam, The Netherlands
Vehicle: SLK 350 2006
Posts: 39
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 8
Thanked 6 Times in 2 Posts
(Thread Starter)
Fault codes ESP and Transmission, SLK R171 limp mode

I was just about to make the MOT appointment... But then....

During driving, after 10 minutes, the error "Speedtronic drive to workshop" and "ESP malfunction! Visit workshop!" came up (together with short loss of power, failing of cruise control and limp mode). After some hours of being turned off, the car will drive with no errors and no limp mode. And then, after 10 minutes, the same thing happens again...

We used Xentry to look at the fault codes of my SLK R171 350 from 2006.

Fault codes from the ESP control unit:
C1122 L6/3 (left rear speed sensor): Signal fault
C1112 L6/2 (right front speed sensor): Signal fault
C1102 L6/1 (left front speed sensor): Signal fault
C1707 Cruise control: consequential fault. Process first of all all the other stored fault codes

The transmission had a fault code too. I will have to look it up.

I've read that SLKs are sensitive for a bad battery (I have Bosch S5 008 77Ah 780A), and since it's really strange that almost all speed sensors fail at exactly the same time, I'm thinking these fault codes and errors can be related to a bad battery. Also, during diagnosting we were normalizing the seats and saw the voltage drop from 12.4V to 9V. I believe a healthy battery should last a bit longer without the engine running, right? Has someone experienced similar fault codes and ESP/Speedtronic error because of a bad battery as well?

Thank you very much in advance!
vennarenate is offline  
Sponsored Links
Advertisement
 
#2 Old 04-12-2019
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: 2009 SLK 350 (Bluebadger), MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 22,342
Country:
Chats: 0
Mentioned: 249 Post(s)
Tagged: 0 Thread(s)
Quoted: 2206 Post(s)
Thanks: 1,912
Thanked 1,424 Times in 1,311 Posts
Garage
If you search you will find several similar threads on poor battery causing a wide range of gremlins.
That sounds like the issue.

https://www.slkworld.com/new-members...searching.html
frogfoot likes this.

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is online now  
#3 Old 04-12-2019
Long Time Member

 
frogfoot's Avatar
 
Join Date: Sep 2009
Vehicle: 2005 slk
Posts: 3,564
Country:
Chats: 1
Mentioned: 153 Post(s)
Tagged: 1 Thread(s)
Quoted: 328 Post(s)
Thanks: 1,754
Thanked 912 Times in 454 Posts
Garage
A weak battery supplying lower than normal voltage to ecu could then cause the ecu to chuck out various fault codes at once.

Clear codes and charge battery over night and give it a good road test and then scan for codes again

Also run a starting and charging test on Xentry / Das. Plus go into active Parameters on abs ecu and select speeds sensors , carry out quick rd test to see if all 4 wheels reading the same to rule out duff sensors ect


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Designo 6speedMT 350........My weekend , Holiday Transport since 2008
frogfoot is offline  
 
#4 Old 05-02-2019
Registered Users
 
vennarenate's Avatar
 
Join Date: Apr 2016
Location: Rotterdam, The Netherlands
Vehicle: SLK 350 2006
Posts: 39
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 8
Thanked 6 Times in 2 Posts
(Thread Starter)
Fault Code 0703 Crankshaft position sensor

Battery got replaced, still had the problems. Looked again with Xentry at the fault codes
Code 0703 B70 (Crankshaft Hall sensor): Check wiring of signal line and voltage. (P0335)

The previous fault codes (speed sensors en cruise control) were probably related to this one, because when we replaced the crankshaft position sensor, the car didn't show any problems! The fault codes of the speed sensors and cruise control didn't came back.
vennarenate is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R171 SLK Class Cars > DAS/STAR Coding

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List




Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it the ESP Module? 2nd Opinion Appreciated Waiheke Tires, Wheels, Brakes & Suspension 8 04-02-2019 06:17 PM
Resolved - R172 SLK 250 - ABS Sensor Fault Codes Laurence Baker SLK R172 General Discussion 3 11-02-2018 06:37 PM
SLK R171 not starting duncanadamsxxx SLK R171 General Discussion 12 04-06-2017 04:53 AM
Great Article from Auto Bild Klassik (Classic). Desert_SLK SLK R170 General Discussion 3 06-26-2014 11:02 AM
ESP Sport mode randombloke AMGs 3 10-11-2013 08:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.