Can I use DAS to check proper function of ignition coils? - Mercedes Benz SLK Forum

DAS/STAR Coding Any links or post’s leading to pirated software will be immediately deleted. SLKWORLD is not responsible for any damage caused by miscoding, use at your own risk.

 
LinkBack Thread Tools
#1 Old 11-09-2017
Registered Users
 
Join Date: Nov 2015
Location: Eastern US
Vehicle: 2005 SLK 350
Other Toys: H20 V-Dubs, MK1s
Posts: 2,026
Country:
Chats: 0
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 409 Post(s)
Thanks: 0
Thanked 67 Times in 67 Posts
Garage
(Thread Starter)
I?m getting what feels like an old fashioned misfire. OK I admit it?s on the the e320 but still MB and basic principles are the same. The car idles smoothly but while driving I?m convinced it?s misfiring slightly. The beast has 12 plugs so I think it?s at least possible that one is not getting fire or not at the right time. I?m hoping that it?s just a faulty coil (2005 145k bone stock). I?m thinking I can use DAS to get live data while driving but honestly don?t know where to start.

Help? Advice? General hazing? Thank you in advance.
Roxanne7169 is offline  
Sponsored Links
Advertisement
 
#2 Old 11-10-2017
Premium Member
 
i860's Avatar
 
Join Date: Dec 2013
Location: Dorset
Vehicle: SLK 350 R171 2004
Other Toys: Mercedes W204 C280 Elegance
Posts: 3,405
Country:
Chats: 0
Mentioned: 396 Post(s)
Tagged: 2 Thread(s)
Quoted: 843 Post(s)
Thanks: 78
Thanked 605 Times in 534 Posts
If I remember correctly there is an option where the machine will run lean on each cylinder to make it easy to detect a misfire.
i860 is online now  
#3 Old 11-10-2017
Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: 2009 SLK 350 (Bluebadger), MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 21,303
Country:
Chats: 0
Mentioned: 238 Post(s)
Tagged: 0 Thread(s)
Quoted: 2121 Post(s)
Thanks: 1,850
Thanked 1,361 Times in 1,249 Posts
Garage
Quote:
Originally Posted by Roxanne7169 View Post
I?m getting what feels like an old fashioned misfire. OK I admit it?s on the the e320 but still MB and basic principles are the same. The car idles smoothly but while driving I?m convinced it?s misfiring slightly. The beast has 12 plugs so I think it?s at least possible that one is not getting fire or not at the right time. I?m hoping that it?s just a faulty coil (2005 145k bone stock). I?m thinking I can use DAS to get live data while driving but honestly don?t know where to start.

Help? Advice? General hazing? Thank you in advance.
Just had this on the 350.
Eventually started missing at tickover too.

Started with O2 sensor, slight improvement.
New plugs cured the issue.

The plugs that were in were relatively new and have been returned under warranty.

Swapping plugs, coils and seeing if the fault changes cylinder is the way to go if you have a reader.

(Don't tell Sarge that I have not yet got one)

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is offline  
 
#4 Old 11-10-2017
Registered Users
 
Join Date: Nov 2015
Location: Eastern US
Vehicle: 2005 SLK 350
Other Toys: H20 V-Dubs, MK1s
Posts: 2,026
Country:
Chats: 0
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 409 Post(s)
Thanks: 0
Thanked 67 Times in 67 Posts
Garage
(Thread Starter)
Thanks for this input. The plugs and wires are new Bosch. That didn?t show much improvement. I replaced the camshaft sensor and it straightened up quite a bit, coupled with a new MAF (probably was not necessary). However I?m still not satisfied and wish to diagnose the coils. At $50/each fir Bosch I?m not too inclined to replace them all just yet.

Again, THANKS. And I won?t say a word to Sarge I promise.
Roxanne7169 is offline  
#5 Old 11-10-2017
Registered Users
 
Join Date: Nov 2015
Location: Eastern US
Vehicle: 2005 SLK 350
Other Toys: H20 V-Dubs, MK1s
Posts: 2,026
Country:
Chats: 0
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 409 Post(s)
Thanks: 0
Thanked 67 Times in 67 Posts
Garage
(Thread Starter)
Quote:
Originally Posted by i860 View Post
If I remember correctly there is an option where the machine will run lean on each cylinder to
make it easy to detect a misfire.
I will poke around in STAR and see what I can find. MChild has advised me to look in the engine ECU area. Any and all information, advice, or guidance will be most welcomed as I?ve not yet done anything like this. I am a ?babe in the woods?, as the expression goes.
Roxanne7169 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R171 SLK Class Cars > DAS/STAR Coding

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Just popped a SmartTOP v2 into my '07 SLK280 MojitoLoco General Modifications R171 346 4 Weeks Ago 11:18 AM
SLK pick up list ierax SLK R171 General Discussion 13 02-05-2018 10:15 AM
A and B Service Questions HBK SLK R170 General Discussion 7 06-25-2011 10:15 PM
Check Engine Light AaronHartwell General Discussion 2 05-23-2010 10:38 AM
Check Engine AaronHartwell SLK R170 General Discussion 2 05-23-2010 12:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.