Car wouldn't start, then ESP warning - Mercedes Benz SLK Forum

AMGs For those high performance Mercedes-Benz R170/R171/R172 cars tuned by AMG

 3Likes
  • 1 Post By OTM2017
  • 1 Post By OTM2017
  • 1 Post By OTM2017
 
LinkBack Thread Tools
#1 Old 01-10-2019
Registered Users
 
Join Date: Sep 2018
Location: Rural America
Vehicle: 2005 SLK 55 AMG. Black on Black
Posts: 7
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Car wouldn't start, then ESP warning

Came out from shopping at grocery car, put key into ignition, dash lit up, then turned it and nothing. Took key out, waited for a few seconds, did again, same results. Nothing. Turned key on and the radio did come on and the rest of the instrument cluster too...but was making a strange clicking/powering up sound in the center console. Waited ten minutes---called wife to see if she could pick me up---then it turned over and started.
Car: 2005 SLK55 AMG, 118,020 miles. New battery last month. Got an ESP warning once last week when I took a mustang to task at a stop light. 0 to way too fast in way too quick...lit the dash with the ESP warning take to shop. Went off when I shut off car, not seen it since this afternoon. No malfunction listed...only when I drop the top once did I get a malfunction that disappeared by the time the top was in the trunk.
Ideas? Searched about, but the combo of not starting/esp warning doesn't come up---or I'm incompetent in the search department.
OTM2017 is offline  
Sponsored Links
Advertisement
 
#2 Old 01-10-2019
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 90,551
Country:
Chats: 38
Mentioned: 445 Post(s)
Tagged: 5 Thread(s)
Quoted: 6460 Post(s)
Thanks: 3,219
Thanked 10,970 Times in 8,334 Posts
Might move this thread to r171 section for you as it is probably not an AMG thing

You said new battery last month. Have you had this 'new' battery tested? It might not be as new as you would hope.

All your symptoms sound like the gremlins one gets when a bad/going bad battery

esp common on a take off like that unless u have a lsd or turn the esp light off before racing


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 01-10-2019
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: 2009 SLK 350 (Bluebadger), MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 22,396
Country:
Chats: 0
Mentioned: 249 Post(s)
Tagged: 0 Thread(s)
Quoted: 2213 Post(s)
Thanks: 1,915
Thanked 1,425 Times in 1,312 Posts
Garage
I suspect that you have two separate issues.

Did the car start every time you turned the key?
Try cleaning the keyhole with cotton buds.
They get dirty.

There is a sensor that ensures gear is in park, that can go faulty.

You say no malfunction listed. Have the codes been read with a DAS reader?

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is offline  
 
#4 Old 01-11-2019
Registered Users
 
Join Date: Sep 2018
Location: Rural America
Vehicle: 2005 SLK 55 AMG. Black on Black
Posts: 7
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
My apologies if I put this in wrong section...noobie mistake
Have not tested the battery, but will. Reputable shop owned by the former owner of the local MB dealership. Interstate battery with 60 month guaranty; so will check that. It did do exactly what it did when the battery died...then however, it just died and nothing turned on again.
jbanks15 likes this.
OTM2017 is offline  
#5 Old 01-11-2019
Registered Users
 
Join Date: Sep 2018
Location: Rural America
Vehicle: 2005 SLK 55 AMG. Black on Black
Posts: 7
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
I will check the switch area again. It started up and the last thing I did before then was to buff the key end on my blue jeans. Could the battery on the fob or the fob itself be bad? I have the older all black one and it's pretty beat up. Gave the new silver edged one to my wife. She's never had a problem---just complains how stiff the ride is and how low to the ground it is and how fast it is...
Have not put it on a DAS reader. Have a reader that reads MBs, but from what I'm reading on this forum, they don't pick up everything everything even they they 'supposedly' do...go figure, marketing hype!

First week in January in Iowa and have had the top down everyday except yesterday---50mph winds and 26 degrees (-8F windchill). You cannot be unhappy with the top down in a convertible Mercedes roadster!
Terminal likes this.
OTM2017 is offline  
#6 Old 01-11-2019
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 90,551
Country:
Chats: 38
Mentioned: 445 Post(s)
Tagged: 5 Thread(s)
Quoted: 6460 Post(s)
Thanks: 3,219
Thanked 10,970 Times in 8,334 Posts
Not the expert but was told the battery in the fob has nothing to do with starting the car...just for lock/unlock functions.
eis starts the car

you have the other fob to try it?


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#7 Old 01-24-2019
Registered Users
 
Join Date: Sep 2018
Location: Rural America
Vehicle: 2005 SLK 55 AMG. Black on Black
Posts: 7
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Many thanks to all the help. Here is what I have found...
No issues for about a week. Then last Tuesday, started it up and no problems EXCEPT, spedo, tach or any lights/functions on the HVAC controls. The message LCD was stuck at mileage and wouldn't cycle. Radio worked and turned on...even sirius XM which is hit or miss on a good day. Drove around the block---no tach/no spedo harder than one thinks!--drove home and shut it off. Waited a minute and started again, no problems!
Temperature? A balmy 16 degrees F/-9C. Why was it parked outside? Quick tale, was not in town when my wife moved us last November and garage full of boxes. Moved boxes, parked SLK in garage. This morning it was -11F/-24C, garage a nice 33F/0C, started, no issues.
Knowing electronics, this seems about right as the relays/SAMs are rated to -40F/-40C, but those are under ideal conditions. (Yes, that cold CAN have ideal conditions!)
Added benefit---no scrapping/deicing in the mornings!
Wife's GLK parked outside--single car condo garage--never an issue. Guess MB expects folks to drive the SUVs in all conditions?
MartinatMersea likes this.
OTM2017 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > General Discussion about Mercedes Benz SLKs > AMGs

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lotus Elise Named Slowest Depreciating Performance Car Berliner Heckflosse Off Topic 1 05-17-2017 02:00 PM
Alarm goes off when unlocking door - car won't start and gives "Start Error" phd gator SLK R170 General Discussion 23 06-14-2016 04:50 PM
UK Mercedes SLK230, Low 35k miles with FMBSH billy610 SLK Cars For Sale 0 10-22-2015 01:39 PM
Urgent : car won't start gilafro SLK R171 General Discussion 21 09-04-2014 04:50 AM
Vancouver Island Sport/Import/Tuner Poker Run for Camp Shawnigan DDonovan Canada Region 18 11-14-2012 07:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.