Problem with torque converter - Mercedes Benz SLK Forum

AMGs For those high performance Mercedes-Benz R170/R171/R172 cars tuned by AMG

 
LinkBack Thread Tools
#1 Old 07-04-2018
Registered Users
 
Maciej Gawryszewski's Avatar
 
Join Date: Mar 2016
Location: Warsaw
Vehicle: R171 2004 55AMG
Other Toys: TRANSPORTER T5
Posts: 17
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Problem with torque converter

Hi!

In november I got my 55AMG and I love it. I sold my SLK 200…

BUT!

The car was cheap couse gearbox (7g tronic 722.9) was damaged. The transmission tugged but in strange way. The gears changed smoothly and from the beginning I thought that the problem is in the clutch and not in the gearbox. I wanted to solve the problem. Unfortunately - the mechanic wanted to cheat on me, he said gearbox is destroyed, so i swapped it and I stayed withe the problem. When I changed the mechanic which is unfortunately very far away, he solved the problem. In the settlement, he accepted my old gearbox, which was in parts. He said that my original gearbox was in perfect condition and made no sense to change it . The problem lies in the clutch. He swapped the torque converter and put one from S500. He solved the problem! During going back home from mechanic (about 400km) when I pushed full gas, and 3 gear, sometimes at 2 gear the the clutch suddenly pulled off the connection. This situation was repeated sometimes for about a month. Suddenly, something broke down. When I drive smoothly, everything is ok. When i push gas stronger - the drive system is disconnecting, the car is not going, only engine speed is incerasing. Than, gearbox put 5th gear and it is the only possible gear till I turn off the engine and start it again. Sometimes, even when I drive smoothly, the drive system can disconnect. It looks like the power of the car was to much for it. I'm not sure but the car is modified probably. The seller said the SLK was modified for 420 horsepower. Anybody has any ideas? This fault is different from the last one when the transmission tugged. To strong car destroyed another clutch? Is it possible to mount stronger torque converter from SL55 AMG with 500 horsepower? Does this part fit?
Maciej Gawryszewski is offline  
Sponsored Links
Advertisement
 
#2 Old 07-04-2018
DAS/STAR Registered Owner
 
Lioninstreet's Avatar
 
Join Date: Jun 2014
Location: Florida
Vehicle: '06 SLK55
Other Toys: Legos, Play Doh, TinkerToys, Hotwheels
Posts: 450
Country:
Chats: 0
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Thanks: 65
Thanked 34 Times in 27 Posts
Garage
When you say "clutch" my guess is you are referring to the lock up of the torque converter since '55's transmissions are automatic shift and don't have clutches in the traditional sense of the word (you don't need to row your way thru the gears from first to 6th).


Are you saying the transmission is slipping when you press on the gas, as if the motor rpm rises but the vehicles speed doesn't really change?


By the way, if it puts your mind at ease at all, with under 500 hp at the wheels, there is virtually no way your engine has enough power to trash your tranny or torque converter.
Lioninstreet is online now  
#3 Old 07-05-2018
Registered Users
 
Join Date: Sep 2017
Location: Orlando
Vehicle: 05 SLK55 & 06 Kleemann 55K S8
Other Toys: 335Xi (modded) Suzuki GSXR1000
Posts: 684
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 208 Post(s)
Thanks: 4
Thanked 60 Times in 60 Posts
Your torque converter is not locking up any more, it is staying unlocked.
jet_fl is offline  
 
#4 Old 07-06-2018
Registered Users
 
Maciej Gawryszewski's Avatar
 
Join Date: Mar 2016
Location: Warsaw
Vehicle: R171 2004 55AMG
Other Toys: TRANSPORTER T5
Posts: 17
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Thanks for replies. So, are you sure those components are quite strong and should manage 420hp?

I said clutch - I know in the car is torque converter, not clutch exactly, but in Poland at torque converter we say "hydrokinetic clutch", but if it is misleading, I'll use torque converter word. Of cousre I have quite a lot of knowlege about how TC, transmission works, I repair lots things by my hands, my father is an mechanic.

Yes, exactly - the transmission is slipping when I press on the gas, as if the motor rpm rises but the vehicles speed doesn't really change. It looks as if I press a clutch in a car with a manual transmission. When I add gas - the car does not accelerate. When I take my foot off the gas - the motor rpm drops. After that, the gearbox put the 5th gear and it's the only possible gear which works till I turn off the engine and start it again. What is strage - when the car is cold, the 1st and 2sd gears works correctly. The problem appears on 3rd gear. (but sometimes on cold engine everything works perfect on every 7 gears! :O) When engine is hot, the problem appears ond 1st and 2nd gear too… Looks exactly like if i had press the clutch pedal in car with manual gearbox and press on the gas - the car is not moving. ... I will try to replace torque converter, should it help? I was wondering, maybe there's something wrong with oil pump? I don't know. It's the middle of the summer and my lovely car doesn't work
Maciej Gawryszewski is offline  
#5 Old 07-06-2018
Premium Member
 
Durkatlon's Avatar
 
Join Date: Nov 2009
Location: San Diego, CA
Vehicle: 2009 SLK55
Posts: 4,895
Country:
Chats: 0
Mentioned: 48 Post(s)
Tagged: 0 Thread(s)
Quoted: 271 Post(s)
Thanks: 390
Thanked 1,326 Times in 792 Posts
Garage
Could this be a conductor plate issue? The symptom of the car sticking to one gear, until the engine is turned off and restarted sounds like the typical conductor plate / speed sensor problem...
Durkatlon is offline  
#6 Old 07-06-2018
Registered Users
 
Join Date: May 2015
Location: London
Vehicle: 05 55
Other Toys: My little Pony
Posts: 1,615
Country:
Chats: 0
Mentioned: 58 Post(s)
Tagged: 0 Thread(s)
Quoted: 533 Post(s)
Thanks: 42
Thanked 108 Times in 103 Posts
^ Agreed - sounds exactly like he symptoms mine had prior to the repair.
Terminal is offline  
#7 Old 07-06-2018
Premium Member

 
Turdo2's Avatar
 
Join Date: Apr 2013
Location: Kansas
Vehicle: 1999 SLK 5.4 M113 V8
Other Toys: Ram 2500, Plymouth Duster
Posts: 1,306
Country:
Chats: 0
Mentioned: 382 Post(s)
Tagged: 1 Thread(s)
Quoted: 348 Post(s)
Thanks: 0
Thanked 76 Times in 68 Posts
Garage
Sounds like a conductor plate to me as well. did all the codes get cleared out of the TCU?

could still be in limp-home mode.
Turdo2 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > General Discussion about Mercedes Benz SLKs > AMGs

Bookmarks

Tags
amg, problem, torque converter

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent Starting Problem edzed SLK R171 General Discussion 44 07-28-2018 03:38 PM
722.9 Transmission - Torque Converter Drain Plug gchetta SLK R171 General Discussion 2 01-29-2018 07:28 PM
Help needed with a possible problem please ?? curro101 SLK R171 General Discussion 15 06-15-2014 06:34 PM
Using torque wrench on spark plugs, help DIYGirl SLK R170 General Discussion 10 08-16-2013 02:07 PM
blown transmission and torque converter nelli AMGs 21 10-17-2010 09:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.