AMG32 starting issues makin' me crazy! - Mercedes Benz SLK Forum

AMGs For those high performance Mercedes-Benz R170-SLK 32/R171-SLK 55/R172-SLK 55 cars tuned by AMG -

 3Likes
  • 1 Post By thirteendog
  • 2 Post By Firemist 04
 
LinkBack Thread Tools
#1 Old 03-24-2013
Registered Users
 
Join Date: Mar 2013
Location: SW Virginia, USA
Vehicle: 2004 SLK32 AMG, stock with 50,000 miles
Other Toys: 1971 Camaro Z/28, 1972 Camaro SS, 1970 Pontiac GTO, 1991 Mitsubishi Eclipse Tsi/AWD
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 15
Thanked 0 Times in 0 Posts
Garage
(Thread Starter)
AMG32 starting issues makin' me crazy!

Greetings!
I'll try to keep this brief . . . 2004 SLK32 AMG. Initially wouldn't restart when engine was at operating temp. Cool down a few minutes, restarted, then stalled in traffic at idle the following afternoon . . .Time to get after the Gremlins!
OBD II code reader displayed:
P0335
P0410
Replaced CPS, this turned out to be a Taiwan manufactured unit, ?
No noticeable results after replacement . . . Thank God for small hands!
Replaced K40 relay, new MB dealer unit.
Car started, ran at idle, revved engine to about 1500 rims for 30 seconds or so as this is thought to reset CPS, ?
Pulled onto the street and stalled out . . . Sputtered a bit and restarted, ran fine with good power, drove a couple miles. Tried to restart after car cooled down for several hours and wouldn't start, then Started right up this morning!
NOTE: Throughout this problem and for several months before there has been an increasing smell of raw gas when starting and shutting down.
Thanks in advance for any help or direction with this . . . My budget won't withstand a repair visit to the dealership just now!
Firemist 04 is offline  
Sponsored Links
Advertisement
 
#2 Old 03-24-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,239
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6498 Post(s)
Thanks: 3,232
Thanked 11,035 Times in 8,392 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!



You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.

Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response and only once. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message) - capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread, make a post, click on the ‘paper clip’ or go to ‘advanced’ and then ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’!
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Also vote or enter our Ride of the Month competition: https://www.slkworld.com/rotm-submissions-voting/

Thank you
Jeff
Moderator/Founding Member


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 03-24-2013
Registered Users
 
Join Date: Mar 2013
Location: SW Virginia, USA
Vehicle: 2004 SLK32 AMG, stock with 50,000 miles
Other Toys: 1971 Camaro Z/28, 1972 Camaro SS, 1970 Pontiac GTO, 1991 Mitsubishi Eclipse Tsi/AWD
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 15
Thanked 0 Times in 0 Posts
Garage
(Thread Starter)
Bad gas.

One other thought, I filled up with a new brand of non-ethanol gas prior to these problems although the slight raw gas smell had been occurring for some time.
Starting issues began when I was down to just over a quarter tank remaining
Could the problems here be due to bad gas or water in the gas I purchased?
Firemist 04 is offline  
 
#4 Old 03-24-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,239
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6498 Post(s)
Thanks: 3,232
Thanked 11,035 Times in 8,392 Posts
search for 'egg smell', top right
bad gas can always cause issues
was it 91 or 93?
some techron might not hurt:

https://www.slkworld.com/general-disc...esitation.html


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#5 Old 03-24-2013
Registered Users
 
Join Date: Mar 2013
Location: SW Virginia, USA
Vehicle: 2004 SLK32 AMG, stock with 50,000 miles
Other Toys: 1971 Camaro Z/28, 1972 Camaro SS, 1970 Pontiac GTO, 1991 Mitsubishi Eclipse Tsi/AWD
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 15
Thanked 0 Times in 0 Posts
Garage
(Thread Starter)
Supposedly 93 octane premium sans ethanol . . . More expensive but seemed to run better and after all the bad $hit I've been reading about ethanol laced gas I was game to try it out. The down side is that these are off brand small dealers for the most part and at the price, may not move the volume that larger main stream stations do . . . Which may invite water to get into the mix more readily. Still have to wonder about those error codes though. Amsoil makes a really good FI gas additive that has done the trick with gas issues in the past. I use all their oil and lubes and have been very pleased with their performance.
Firemist 04 is offline  
#6 Old 03-25-2013
Registered Users
 
Join Date: Aug 2009
Location: Lebanon, Tennessee
Vehicle: 2015 Ford Focus ST
Posts: 542
Country:
Chats: 2
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 15
Thanked 142 Times in 51 Posts
You mention replacing the CPS. I'm not sure I'm reading it right though. Did you replace it with a Bosch part or a off brand part?
leapyfish likes this.
thirteendog is offline  
#7 Old 03-25-2013
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,283
Country:
Chats: 0
Mentioned: 584 Post(s)
Tagged: 0 Thread(s)
Quoted: 903 Post(s)
Thanks: 155
Thanked 516 Times in 477 Posts
Did you clear the codes after replacing the CPS, and if yes, have either of the codes come back?

If water in the gasoline was a problem, I would've expected your problem to start immediately after filling up -- not after consuming 3/4 of the tank (water is heavier than gas). Also your symptoms wouldn't be different hot vs. cold -- water is water.

I've never heard of "resetting the CPS" as you mention.
efair is online now  
#8 Old 03-25-2013
Registered Users
 
Join Date: Mar 2013
Location: SW Virginia, USA
Vehicle: 2004 SLK32 AMG, stock with 50,000 miles
Other Toys: 1971 Camaro Z/28, 1972 Camaro SS, 1970 Pontiac GTO, 1991 Mitsubishi Eclipse Tsi/AWD
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 15
Thanked 0 Times in 0 Posts
Garage
(Thread Starter)
At idle. . .

Just got through our spring blizzard here . . . No time to refill the tank with fresh oline.
Previously, After replacing the CPS and K40 relay, which the CPS turned out to be a Taiwan manufactured unit . . . the car restarted fine. . . After it cooled down for several hours it wouldn't restart. Only one remaining error code - P0335 on the CPS. Tried to start again after 5 hours and she fired right up.
Just now restarted and still have the P0335 CPS error code present.
Should I try to refill with fresh gas and additive in case my gas tank has water in it?
Any thoughts?
Firemist 04 is offline  
#9 Old 03-25-2013
Registered Users
 
Join Date: Mar 2013
Location: SW Virginia, USA
Vehicle: 2004 SLK32 AMG, stock with 50,000 miles
Other Toys: 1971 Camaro Z/28, 1972 Camaro SS, 1970 Pontiac GTO, 1991 Mitsubishi Eclipse Tsi/AWD
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 15
Thanked 0 Times in 0 Posts
Garage
(Thread Starter)
Codes . . .

Oh and the codes cleared themselves after restarting 2 or3 time yesterday.
Firemist 04 is offline  
#10 Old 03-31-2013
Registered Users
 
Join Date: Mar 2013
Location: SW Virginia, USA
Vehicle: 2004 SLK32 AMG, stock with 50,000 miles
Other Toys: 1971 Camaro Z/28, 1972 Camaro SS, 1970 Pontiac GTO, 1991 Mitsubishi Eclipse Tsi/AWD
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 15
Thanked 0 Times in 0 Posts
Garage
(Thread Starter)
Problem solved!

I'll try to write a more comprehensive post on this soon since there are so many people with the same problem/s. I should have resolved this much sooner but as it turned out, the CPS originally purchased to correct the starting problem was made in Taiwan and was junk.
Long story made short . . .
Don't replace your CPS with a part manufactured anywhere other than Germany. I paid the same price for a German manufactured Duralast, ($55) as the crappo Taiwan made part that didn't work. You don't generally expect a new part to be faulty but it happens . . . No matter where it's made.
efair and Der Flieger like this.
Firemist 04 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > General Discussion about Mercedes Benz SLKs > AMGs

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Problem Super Dave SLK R170 General Discussion 19 01-04-2017 03:23 PM
SLK 350 Starting Issues my1stmerc SLK R171 General Discussion 2 06-04-2016 06:31 PM
slk55amg starting issues ?? ian55amg SLK R171 General Discussion 1 01-21-2011 12:29 AM
Ongoing problems and dealer issues arosamond General Discussion 19 12-31-2008 09:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.