55 will crank, but won't start - Mercedes Benz SLK Forum

AMGs For those high performance Mercedes-Benz R170-SLK 32/R171-SLK 55/R172-SLK 55 cars tuned by AMG -

 2Likes
  • 1 Post By quicktwinturbo
  • 1 Post By tu99a
 
LinkBack Thread Tools
#1 Old 05-26-2012
Registered Users
 
Join Date: Jun 2011
Location: British Columbia, Canada
Vehicle: 2006 Designo Graphite SLK55 AMG
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 6 Times in 4 Posts
(Thread Starter)
55 will crank, but won't start

Got stuck at the mall today when my 55 would just keep cranking, but not fire. After letting it sit for like 15 minutes it started, but now the CEL is on. After searching the world wide internets it sounds like the CPS (crankshaft position sensor). Going to get it diagnosed on monday to be sure, but really sounds like this is the problem. Has anyone else here experienced this? Can I pick up the part online somewhere? Is it a DIY kinda job? Thanks alot!
tu99a is offline  
Sponsored Links
Advertisement
 
#2 Old 05-26-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,724
Country:
Chats: 38
Mentioned: 470 Post(s)
Tagged: 5 Thread(s)
Quoted: 6543 Post(s)
Thanks: 3,246
Thanked 11,082 Times in 8,436 Posts
i would ask how old your battery is first


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 05-26-2012
Registered Users
 
Join Date: Jun 2011
Location: British Columbia, Canada
Vehicle: 2006 Designo Graphite SLK55 AMG
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 6 Times in 4 Posts
(Thread Starter)
Its only a few months old
tu99a is offline  
 
#4 Old 05-26-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,724
Country:
Chats: 38
Mentioned: 470 Post(s)
Tagged: 5 Thread(s)
Quoted: 6543 Post(s)
Thanks: 3,246
Thanked 11,082 Times in 8,436 Posts
ok, just checking.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
The Following User Says Thank You to jbanks15 For This Useful Post:
#5 Old 05-26-2012
Registered Users
 
Join Date: Oct 2011
Location: Riverside
Vehicle: 09' SLK55 w'AMG Performance Package
Posts: 500
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 2
Thanked 96 Times in 65 Posts
Quote:
Originally Posted by tu99a View Post
Got stuck at the mall today when my 55 would just keep cranking, but not fire. After letting it sit for like 15 minutes it started, but now the CEL is on. After searching the world wide internets it sounds like the CPS (crankshaft position sensor). Going to get it diagnosed on monday to be sure, but really sounds like this is the problem. Has anyone else here experienced this? Can I pick up the part online somewhere? Is it a DIY kinda job? Thanks alot!

The part is around $30-$40 and just a screw holding it. It very easy to replace. It located on the back of the engine (driver side) between the engine and tranny meet.
Klinh is offline  
The Following User Says Thank You to Klinh For This Useful Post:
#6 Old 05-26-2012
Registered Users
 
Join Date: Oct 2011
Location: Riverside
Vehicle: 09' SLK55 w'AMG Performance Package
Posts: 500
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 2
Thanked 96 Times in 65 Posts
Klinh is offline  
The Following User Says Thank You to Klinh For This Useful Post:
#7 Old 05-26-2012
Registered Users
 
Join Date: Aug 2010
Location: Korea, IL, GA, SC
Vehicle: C55(05) and SLK55(06)
Posts: 270
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 70
Thanked 39 Times in 24 Posts
Garage
FaultyCPS (Either camshaft position or crankshaft position sensor).. This is a common issue for C55 / SLK55
quicktwinturbo is offline  
The Following User Says Thank You to quicktwinturbo For This Useful Post:
#8 Old 05-27-2012
aka John

 
UK-C200's Avatar
 
Join Date: May 2008
Location: Richmond, Tx
Vehicle: LHD Black SLK350, LHD Firemist SLK55
Other Toys: Nacra F18
Posts: 13,012
Country:
Chats: 1143
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Thanks: 1,712
Thanked 2,920 Times in 2,028 Posts
Quickwi's right, it's a know potential problem. Good news is it throws very specific codes, so that's your first step!



UK-C200 is offline  
The Following User Says Thank You to UK-C200 For This Useful Post:
#9 Old 05-27-2012
Registered Users
 
Join Date: Jun 2011
Location: British Columbia, Canada
Vehicle: 2006 Designo Graphite SLK55 AMG
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 6 Times in 4 Posts
(Thread Starter)
Thanks for the help gentlemen, where would you recommend pickin up the part?
tu99a is offline  
#10 Old 05-27-2012
Registered Users
 
Join Date: Aug 2010
Location: Korea, IL, GA, SC
Vehicle: C55(05) and SLK55(06)
Posts: 270
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 70
Thanked 39 Times in 24 Posts
Garage
Quote:
Originally Posted by tu99a View Post
Thanks for the help gentlemen, where would you recommend pickin up the part?
Get your car to the dealership or any reputable independent shop who can properly diagnose the problem. That would be your first step

Last thing you want to do is spending your money on parts you didn't need..

Good luck
Galo likes this.
quicktwinturbo is offline  
#11 Old 05-28-2012
Registered Users
 
Join Date: Jun 2011
Location: British Columbia, Canada
Vehicle: 2006 Designo Graphite SLK55 AMG
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 6 Times in 4 Posts
(Thread Starter)
Put the scan tool on it today and it is the CPS, now where do you recommend I pick one up? Stealership here wants $216 and most US parts sites dont seem to want to ship it to Canada.
tu99a is offline  
#12 Old 06-01-2012
Registered Users
 
Join Date: Jun 2011
Location: British Columbia, Canada
Vehicle: 2006 Designo Graphite SLK55 AMG
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 6 Times in 4 Posts
(Thread Starter)
Got the part in from amazon today and installed it, total job took $100 and 15 minutes, glad I did it all myself. Thanks for all the help guys!
macman likes this.
tu99a is offline  
#13 Old 06-01-2012
Premium Member
 
PitchRate's Avatar
 
Join Date: Feb 2012
Location: St. Louis
Vehicle: 2006 SLK55 AMG Black/Black
Posts: 415
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Thanks: 33
Thanked 70 Times in 56 Posts
Garage
Quote:
Originally Posted by tu99a View Post
Got the part in from amazon today and installed it, total job took $100 and 15 minutes, glad I did it all myself. Thanks for all the help guys!
Good job. I sure I came with lots of satisfaction.

I'm older so I drive fast as I have less time left to waste.
PitchRate is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > General Discussion about Mercedes Benz SLKs > AMGs

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
my SLK doesn't want to start!!! SuzaFan SLK R171 General Discussion 20 06-06-2015 08:12 PM
Black & Dekker simple start Dimi190E General Discussion 5 11-11-2010 07:07 PM
SLK intermittently wont crank over - electrical fault finding ?? andyhhh SLK R170 General Discussion 11 09-29-2009 04:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.