First thread - owners list? - Page 2 - Mercedes Benz SLK Forum

 2Likes
Reply
 
LinkBack Thread Tools
#21 Old 10-18-2015
Registered Users
 
Brother_P's Avatar
 
Join Date: Sep 2013
Location: Johannesburg, South Africa
Vehicle: 2005 SLK350
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Maffew View Post
Quote:
Originally Posted by Brother_P View Post
Let me know how yours is treating you. Just had to do some work on my AC compressor. It was causing my engine to stall or alternatively the multiv belt to snap.
Hey Brother P! In just over two years, I must say not badly at all. I bought the car second hand in 2013 and the rear SAM unit needed replacing, none of the rear lights were working. R 10 000.00 later, but it was paid for by the selling dealer. Since then, there was a thrumming vibration that started about six months after I took ownership and I was petrified that it was the diff. It led to "Google doctoring" and I was horrified at the consequence of such a catastrophe. Thankfully, after sending the car in for new tyres, it turned out that one of the rims was buckled (my fault) so I had all four straightened, cleaned up and the vibration's disappeared.

The car is currently slightly out of commission at the moment with the secondary air injection pump having given up the ghost and fright the related circuit board in the front SAM unit. The pump issue is seemingly common and there's a thread on here about diagnosis and (if you're brave enough) DIY repair. Anyhow, both of those need to be replaced. I've been told that I can still drive the car but I'd rather not tempt fate. I'm awaiting delivery of the parts and hope to have him back in fine fettle by the end of next week.

Oh and I changed the poly-belt about 20 000km ago, it had developed a squeak but wasn't too badly worn. I don't like odd noises so I had it seen to. Normal wear and tear that though.

Other than those two issues, one self-imposed, I have absolutely no cause for complaint. I love my Blue Monster and have no intention of selling! This one's a keeper and I'm hoping to add an AMG as a stablemate in the next few years.

How long have you had yours for? Any other issues other than the A/C?

I bought mine 2nd hand in 2013 and this is the only issue I have had with it.
The issue was there from the start but it didnt show itself as something serious until the engine stalling drama started to happen.
This combined with a Bosch workshop who knows nothing about repairng cars except to plug them into a diagnostic machine cost me 5 months, 3 poly-belts and a radiator.

Other than this I replaced shocks and tyres. Bought it at 144000km currently at 200000km.
Brother_P is offline  
Sponsored Links
Advertisement
 
#22 Old 10-19-2015
Registered Users
 
Okkie's Avatar
 
Join Date: Oct 2015
Location: Pretoria
Vehicle: 1999 SLK 230 Kompressor, 2005 C350
Other Toys: Lotus 7's
Posts: 27
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Hi, Okkie from Centurion, Pretoria. W170 230K 203 000km
Okkie is offline  
#23 Old 02-13-2016
jum
Registered Users
 
Join Date: Feb 2016
Location: Cape Town
Vehicle: 2005 SLK350 Fire Opal Red
Posts: 7
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 5
Thanked 0 Times in 0 Posts
Hi all from Cape Town.

Just recently bought a 2005 SLK 350 (R171) and having a great time with it

No major issues (yet!), but some minor bugs (park distance faulty, noisy roof on bumpy roads).

Lekker to be rolling with the top down...
jum is offline  
 
#24 Old 11-11-2016
Registered Users
 
Chippyslk350's Avatar
 
Join Date: Sep 2015
Location: Alberton South Africa
Vehicle: 2005 SLK350 Obsidian Black
Other Toys: Jeep Grand Cherokee 5.7, Honda Accord 2.4 Exec., My Pub..
Posts: 124
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Thanks: 14
Thanked 26 Times in 10 Posts
Garage
Hello All from Alberton SA.. I have just stumbeled over this page / site for South African Owners.. I see a few around here in Alberton on my travels but have not actually met anyone!!... Hope to see someone from around here soon!!
Dave
Attached Images
File Type: jpg 2015.09.28. slk Sunday Run (7).jpg (76.7 KB, 4 views)
Chippyslk350 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Club and Regional Discussion Forum > South Africa

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Seat Heater Failure List - Please add your name. Cookiecrew SLK R171 General Discussion 106 03-06-2015 08:11 AM
Sydney owners meet seanmacc Australia/New Zealand 2 09-19-2013 08:42 PM
Help!..Super Charger issues.. Help! sbhcom SLK R170 General Discussion 43 05-31-2013 03:00 PM
Whats on your Bucket List? Berliner Heckflosse Off Topic 3 01-23-2013 02:47 AM
Get on the Waiting List for Sonax Nano Polish and Fine Abrasive DetailersDomain Caring for your SLK 0 10-18-2012 08:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome