Auto headlight function won't work - Mercedes Benz SLK Forum
SLK R171 General Discussion SLK 200, SLK 280, SLK 300, SLK 350, SLK 55 AMG

 
LinkBack Thread Tools
#1 Old 05-06-2009
Elite SLK World Member
 
HwoALanG's Avatar
 
Join Date: Oct 2006
Location: Dallas, Texas
Vehicle: 2007 SLK 280
Other Toys: COMPUTER? And1 and on
Posts: 509
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 37
Thanked 18 Times in 17 Posts
Send a message via AIM to HwoALanG Send a message via MSN to HwoALanG Send a message via Yahoo to HwoALanG
(Thread Starter)
Auto headlight function won't work

Omg! Have you guys ever had this kind of problem??

I started car this morning and my head light starting to turn on...normal right.
But after sun comes up and I thought headlight would turn off. But no!!
It keep stays on and won't shut off... even in bright sunny day.

So I switch to turn off position and it still stays on!!!

I put into parking light position and still stay on!!

And if I put into manual on headlight position.... fog light comes on and headlight stays on.

Only way I can shut it off is put into off position and turn off the ignition.

I tried anything possible, but I think I might blow up the fuse or something....

I have aftermarket HID... and I hope that's not screwing things up....

And my car is out of warranty... I need help!!

SAM is doing it’s own thing!
Another weird thing I noticed was SRS sign came on this morining but it went away after few min...
gosh... i hope it's not huge problem.....
HwoALanG is offline  
Sponsored Links
Advertisement
 
#2 Old 05-06-2009
Passionate SLK World Member
 
DansSlk's Avatar
 
Join Date: Jun 2006
Location: Wales
Vehicle: 05 55 (Brabus 6.1 S)
Posts: 8,878
Country:
Chats: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 401
Thanked 787 Times in 554 Posts
Send a message via MSN to DansSlk
OK check the headlamp mode on the cluster settings menu is set to Manual, then try setting the switch to Off and see if they respond, it could just be they are set to Auto and the sensor is dirty.

I wouldn't have thought the HID's would be causing this unless some very bad wiring has caused damage at some point, that SRS light is probably nothing to worry about since it reset so fast and it is not related to the headlights in any case.
DansSlk is offline  
#3 Old 05-06-2009
Elite SLK World Member
 
HwoALanG's Avatar
 
Join Date: Oct 2006
Location: Dallas, Texas
Vehicle: 2007 SLK 280
Other Toys: COMPUTER? And1 and on
Posts: 509
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 37
Thanked 18 Times in 17 Posts
Send a message via AIM to HwoALanG Send a message via MSN to HwoALanG Send a message via Yahoo to HwoALanG
(Thread Starter)
Quote:
Originally Posted by DansSlk View Post
OK check the headlamp mode on the cluster settings menu is set to Manual, then try setting the switch to Off and see if they respond, it could just be they are set to Auto and the sensor is dirty.

I wouldn't have thought the HID's would be causing this unless some very bad wiring has caused damage at some point, that SRS light is probably nothing to worry about since it reset so fast and it is not related to the headlights in any case.

Thanks for quick respond. Dan

we always appreciate your help.

It was acting really weird. Everything was failing and I got all kind of warning lights. Include check engine light.

But thank god. I found the cause.

It was the moisture that somehow got into fuse box. Cause I opened up the hood this morning…

and saw Fuse box cover was loosed... and later I found out that I’m missing one of the clips that suppose to hold the fuse box cover...

Gosh... I drove it for all day today and everything is okay now. I think engine bay heat vaporize the moisture.

Thanks again and last question.

Where can I get the fuse box cover clip?? Do I have to buy the cover itself?
HwoALanG is offline  
#4 Old 05-06-2009
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG
Posts: 34,917
Country:
Chats: 38
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 190 Post(s)
Thanks: 1,986
Thanked 5,456 Times in 3,800 Posts
under warranty? take into mb and say, look, missing clip!!


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Premium 1, Multimedia, Lighting packages
Kleemann ECU Tune, headers and downpipes
Thread here:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Llumar (Clear Bra) Paint Protective Film
OEM MB Plexiglass
Clear Side Markers w/amber LED bulbs
LED Parking and License Plate Bulbs
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#5 Old 05-06-2009
Founding Member #2

 
etyu's Avatar
 
Join Date: Jun 2006
Location: Orange County, CA
Vehicle: 2008 SLK 55
Posts: 17,806
Country:
Chats: 11
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 4,400
Thanked 2,851 Times in 2,056 Posts
Garage
Good point

Quote:
Originally Posted by jbanks15 View Post
under warranty? take into mb and say, look, missing clip!!
Good point jbanks

Eddy



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Pewter(cubanitsilber metallic)/Beige, PIII package, Airscarf, Hands-Free Communication System, Lighting package; Designo Black Leather Cover on e-brake handle(Thank you Bill T), SmartTop v3.x, John's 3BFM, M113 AMG OEM air filters, Modified R170 ant., clear side-markers & front parking lamps w/error-free LEDs, chromed front & rear turn indicator lamps, steel mesh at battery bay cover & cabin air intake, sock-over-seatbelt buckles, belt-loop guide protectors, Lamin-X fog lamp protectors, bilateral rear fog lamps enabled, etched ///AMG logo on gear shift knob by Blackrose-etching
etyu is offline  
#6 Old 05-07-2009
Founding Member #7
 
mtiede's Avatar
 
Join Date: Jun 2006
Location: Western New York
Vehicle: 2006 SLK 350
Posts: 2,087
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 261
Thanked 146 Times in 96 Posts
Quote:
Originally Posted by jbanks15 View Post
under warranty? take into mb and say, look, missing clip!!
Original posting says its out of warranty.
mtiede is offline  
#7 Old 05-07-2009
Elite SLK World Member
 
HwoALanG's Avatar
 
Join Date: Oct 2006
Location: Dallas, Texas
Vehicle: 2007 SLK 280
Other Toys: COMPUTER? And1 and on
Posts: 509
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 37
Thanked 18 Times in 17 Posts
Send a message via AIM to HwoALanG Send a message via MSN to HwoALanG Send a message via Yahoo to HwoALanG
(Thread Starter)
Quote:
Originally Posted by mtiede View Post
Original posting says its out of warranty.
thank you !
HwoALanG is offline  
#8 Old 05-07-2009
aka John

 
UK-C200's Avatar
 
Join Date: May 2008
Location: Richmond, Tx
Vehicle: LHD Black SLK350, LHD Firemist SLK55
Other Toys: Nacra F18
Posts: 12,972
Country:
Chats: 1143
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 1,699
Thanked 2,885 Times in 2,013 Posts
A1715400182 is the part number for the cover, the clip is not listed as a separate part.
UK-C200 is offline  
The Following User Says Thank You to UK-C200 For This Useful Post:
#9 Old 05-08-2009
Elite SLK World Member
 
HwoALanG's Avatar
 
Join Date: Oct 2006
Location: Dallas, Texas
Vehicle: 2007 SLK 280
Other Toys: COMPUTER? And1 and on
Posts: 509
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 37
Thanked 18 Times in 17 Posts
Send a message via AIM to HwoALanG Send a message via MSN to HwoALanG Send a message via Yahoo to HwoALanG
(Thread Starter)
Quote:
Originally Posted by UK-C200 View Post
A1715400182 is the part number for the cover, the clip is not listed as a separate part.

god!! i have to buy the cover... gosh~!!

Thanks anyway!!!
HwoALanG is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R171 SLK Class Cars > SLK R171 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now

In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Marginally not Safe for Work. Alfa Romeo Booth at Russian Auto show cyberdrakon Off Topic 1 04-15-2009 02:09 PM
'09 SLK 350 Roof and window function vincent007 SLK R171 General Discussion 30 11-18-2008 04:36 PM
Navi ETA Function X2 DansSlk SLK R171 General Discussion 89 09-20-2008 03:36 PM
computer function RL 1 Ask DansSLK 3 09-16-2007 07:54 PM
Disabling the cornering light function phatchink General Modifications R171 5 06-21-2007 09:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome