Cooling Fan Not Working - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 9Likes
Reply
 
LinkBack Thread Tools
#1 Old 09-23-2013
Registered Users
 
shieldsrs's Avatar
 
Join Date: Mar 2012
Location: Northlake, Tx USA
Vehicle: 2002 SLK 32 Silver sure goes thru rear tires fast
Other Toys: Dragster
Posts: 21
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 23
Thanked 4 Times in 2 Posts
Garage
(Thread Starter)
Cooling Fan Not Working

My coolant light came on not long ago and the car started to get hot, coolant level good. I checked the fan motor and it was binding so I replaced it. Plugged in the new fan, coolant light still on, got car up to temp and a little warmer fan never came on. Researched some, all I can find was replace the fan control module. Plugged in the new module fan doesn't run. Wired the fan to the battery and fan works great then. temp gauge in car also works correctly. Cant find any fuse to check. Looked on line for a wiring diagram to try and trace it down, none found. This is really getting old I need my car to work properly, done all i can do need HELP!!!!

2002 SLK32
shieldsrs is offline  
Sponsored Links
Advertisement
 
#2 Old 09-23-2013
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 68,176
Country:
Chats: 38
Mentioned: 145 Post(s)
Tagged: 3 Thread(s)
Quoted: 3968 Post(s)
Thanks: 2,826
Thanked 9,051 Times in 6,621 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t already.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’.

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.

Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response and only once. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’!
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Post your vin in the Vehicle Datacard Request section to get a datacard (options on your car). http://www.slkworld.com/vehicle-data-card/
Also vote or enter our Ride of the Month competition: http://www.slkworld.com/rotm-submissions-voting/

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Wavetrac LSD thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#3 Old 09-23-2013
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 68,176
Country:
Chats: 38
Mentioned: 145 Post(s)
Tagged: 3 Thread(s)
Quoted: 3968 Post(s)
Thanks: 2,826
Thanked 9,051 Times in 6,621 Posts
moving to r170 general discussion from amg. though you have an amg, more people with r170s might respond in general discussion


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Wavetrac LSD thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
 
#4 Old 09-23-2013
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,597
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 143 Post(s)
Thanks: 555
Thanked 568 Times in 500 Posts
I believe you welcomed him last year.. he's a repair creeper

Auto Dimming Mirrors

none the less.. chime in 170 peeps ;p


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
#5 Old 09-23-2013
Registered Users
 
shieldsrs's Avatar
 
Join Date: Mar 2012
Location: Northlake, Tx USA
Vehicle: 2002 SLK 32 Silver sure goes thru rear tires fast
Other Toys: Dragster
Posts: 21
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 23
Thanked 4 Times in 2 Posts
Garage
(Thread Starter)
Im sorry whats a reapir creeper, did I do something wrong? or say something wrong? If i have Im sorry
shieldsrs is offline  
#6 Old 09-23-2013
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 68,176
Country:
Chats: 38
Mentioned: 145 Post(s)
Tagged: 3 Thread(s)
Quoted: 3968 Post(s)
Thanks: 2,826
Thanked 9,051 Times in 6,621 Posts
I assume she means, one is a repair creeper tht comes in without saying 'welcome' in the new member introduce yourself thread

you can do that now:

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.

then please update your vehicle in your profile like you did your location here:

‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘vehicle’.


and three, what is a dargster? do you mean dragster? you can fix that there also (edit: fixed)


Jeff


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Wavetrac LSD thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#7 Old 09-23-2013
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 68,176
Country:
Chats: 38
Mentioned: 145 Post(s)
Tagged: 3 Thread(s)
Quoted: 3968 Post(s)
Thanks: 2,826
Thanked 9,051 Times in 6,621 Posts
Quote:
Originally Posted by slk320chick View Post
I believe you welcomed him last year.. he's a repair creeper

Auto Dimming Mirrors

none the less.. chime in 170 peeps ;p
I might have welcomed him but he did not post in the new member section.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Wavetrac LSD thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#8 Old 09-23-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,607
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 226
Thanked 360 Times in 261 Posts
Garage
Have you checked fuses under the hood in the black fuse box?
JaysonM is offline  
#9 Old 09-24-2013
Registered Users
 
shieldsrs's Avatar
 
Join Date: Mar 2012
Location: Northlake, Tx USA
Vehicle: 2002 SLK 32 Silver sure goes thru rear tires fast
Other Toys: Dragster
Posts: 21
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 23
Thanked 4 Times in 2 Posts
Garage
(Thread Starter)
Yes I have placed a meter on all fuses under the hood on both side of the engine and in the drivers area all are good
shieldsrs is offline  
#10 Old 09-24-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,607
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 226
Thanked 360 Times in 261 Posts
Garage
Quote:
Originally Posted by shieldsrs View Post
Yes I have placed a meter on all fuses under the hood on both side of the engine and in the drivers area all are good
Where did you get your new fan control module from? (I know this part is not cheap) Are you sure it's working? Perhaps a wire short somewhere then...?
JaysonM is offline  
#11 Old 09-24-2013
Registered Users
 
Join Date: Jan 2013
Location: Greenville SC
Vehicle: 2008 E320 Bluetec(sold 11/14), 2001 SLK 320, 2013 E350
Other Toys: 1972 MGB, 2004 Volvo V70
Posts: 287
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 2
Thanked 37 Times in 33 Posts
Garage
If you have the codes read by someone with the proper reader/SW it will tell you if the module is defective. you will have to spend some bucks to have it done though.
CarolinaBluetec is offline  
#12 Old 09-24-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,607
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 226
Thanked 360 Times in 261 Posts
Garage
Wink

After some time I decided to invest in one of those cheap OBD scanners. Most people say it works for reading codes and clearing them.
I chose this one. Should be here by Friday =) I have a coolant light constantly on on my dashboard. Level is OK. Sprayed the contact cleaner but no change. Will read codes and see what's wrong.
P.S. I'm glad I kept my Android since most of these OBD II scanners are not compatible with iPhones =(
ajberrow likes this.
JaysonM is offline  
The Following User Says Thank You to JaysonM For This Useful Post:
#13 Old 09-26-2013
Registered Users
 
shieldsrs's Avatar
 
Join Date: Mar 2012
Location: Northlake, Tx USA
Vehicle: 2002 SLK 32 Silver sure goes thru rear tires fast
Other Toys: Dragster
Posts: 21
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 23
Thanked 4 Times in 2 Posts
Garage
(Thread Starter)
UPDATE PROBLEM SOLVED !!!!!!
Ok there are 3 fuse boxes under the hood. The standard one in front of the driver we all know about, a larger one to the side of the battery with the ECM in it (yes there are fuses in there) and a small square one in front of the battery with fuses that don’t look anything like a fuse. I am attaching pics of the fuses and the location. These fuses have a constant 12 volts to them all the time regardless of the key position. Each is labeled and the last one is the power for the cooling fan.
The key to this was I went on AllDataDYI and paid the 24.00 US to access my car for one year, all of the electrical schematics are there; plug pin outs and testing procedures. There is a TON of GREAT info there along with pics and r&r procedures. This site flat smokes Mitchell OnDemand. I strongly recommend it for everything about your car as it pertains to repairs and trouble shooting.
Jason I got my Cooling Fan Control Module from AutohauzAZ for 186.00 US. It wasn’t obviously the problem and they are taking it back no questions asked, SUPER customer service from them. I highly recommend them for a parts option.
Thank You Very Much to all who replied with suggestions. They were all greatly appreciated. Now back to my profile to get some pics up there of my AMG and of the Whip (AKA Dragster) for any one who wants to see them. Thanks again PEEPS
Attached Images
File Type: jpg photo 1.jpg (45.2 KB, 114 views)
File Type: jpg photo 2.jpg (64.2 KB, 117 views)

Last edited by shieldsrs; 09-26-2013 at 11:31 AM. Reason: Forgot the pics
shieldsrs is offline  
The Following 3 Users Say Thank You to shieldsrs For This Useful Post:
#14 Old 09-26-2013
Registered Users
 
ajberrow's Avatar
 
Join Date: Sep 2013
Location: Nant-y-moel, S Wales
Vehicle: 2001 R170 230K
Other Toys: 1953 BSA B31 motorcycle, Spirit TA kit car age unknown
Posts: 734
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 143
Thanked 75 Times in 67 Posts
Garage
Glad you sorted that one. Added to favourites
ajberrow is offline  
The Following User Says Thank You to ajberrow For This Useful Post:
#15 Old 09-26-2013
Registered Users
 
shieldsrs's Avatar
 
Join Date: Mar 2012
Location: Northlake, Tx USA
Vehicle: 2002 SLK 32 Silver sure goes thru rear tires fast
Other Toys: Dragster
Posts: 21
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 23
Thanked 4 Times in 2 Posts
Garage
(Thread Starter)
Jason
Check that fuse I just posted about. Start your car and turn the A/C on max. This will engage the cooling fan if it doesn’t turn on. Go to the fuse and meter it with a voltage meter it should read 12 plus volts. If it doesn’t read 12 volts the fuse is bad, but be careful continuing to run your a/c , with no air flow across the condenser it will cause the head pressure to spike high and push Freon out the bypass causing a low Freon condition. If it does read 12 plus volts you may need to replace that control module. Try hooking your cooling fan straight to battery, the tan wire is ground and the black/green is pos. The fan is a counter clock wise rotation. Also with the key off spin your fan by hand to make sure it’s not binding anywhere, if it is replace it as it will pull to many amps and pop the fuse or hurt the control module.
shieldsrs is offline  
#16 Old 09-26-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,607
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 226
Thanked 360 Times in 261 Posts
Garage
Glad you found the solution! I remember I've seen this picture some time ago so I went and checked the fuses but visually they seemed all OK. I don't have a voltage meter right now. Will ask my friend when he comes back. I might want to remove it and inspect it. In case it's bad, do you have the part # for it, or can I get it at a local autoparts store? These doesn't seem like regular fuses...
So far the temperature stays steady between 90-95 and I can hear fan engaging when I'm at the red light standing for a while.

My OBD scanner came in but my Android is in my wife's bag =) Will hook it up in the evening to check for codes.
I also read that windshield washer and oil coolant level share the same circuit so if washer sensor goes bad it may trigger the coolant sensor =(
JaysonM is offline  
#17 Old 09-26-2013
Registered Users
 
shieldsrs's Avatar
 
Join Date: Mar 2012
Location: Northlake, Tx USA
Vehicle: 2002 SLK 32 Silver sure goes thru rear tires fast
Other Toys: Dragster
Posts: 21
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 23
Thanked 4 Times in 2 Posts
Garage
(Thread Starter)
As soon as I got power to mu control mod my coolant light went out. I did remove the power wire from that strip where the fuses are to replace. If you dont have a meter you can take the fuse out and turn it over to look at the link inside. If you do take the power wire off you will get a BSA/ESP warning light. To reseet it, start your car, turn the wheel all the way to the left stop and then all the way to the right stop, then back to center. This will reset it and the light will go out. You will also need to reinput your radio code. Hope this helps
07slk280 likes this.
shieldsrs is offline  
#18 Old 09-26-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,607
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 226
Thanked 360 Times in 261 Posts
Garage
Quote:
Originally Posted by shieldsrs View Post
As soon as I got power to mu control mod my coolant light went out. I did remove the power wire from that strip where the fuses are to replace. If you dont have a meter you can take the fuse out and turn it over to look at the link inside. If you do take the power wire off you will get a BSA/ESP warning light. To reseet it, start your car, turn the wheel all the way to the left stop and then all the way to the right stop, then back to center. This will reset it and the light will go out. You will also need to reinput your radio code. Hope this helps
Thanks, I learned the trick with BAS/ESP many times =)
So, your problem was the fuse, not the control module? I mean your OEM control module was working fine?
JaysonM is offline  
#19 Old 09-27-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,607
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 226
Thanked 360 Times in 261 Posts
Garage
shieldsrs, I did as you described, started the car, turned A/C to max and the fan engaged (not full power though. I guess because the car was cold). Checked the fuse and everything seem fine.
So I hooked up my new ODB II reader and here's what came up:
P202C - Powertrain
P202D - Powertrain
P2007 - Intake Manf Runner Control Stuck Closed bank2 a)

So I searched for codes specific to MB and here's what I found from this PDF:
P202C Coolant thermostat (P0115)
P202C refrigerant temperature regulator (P0115)

P202D B11/4 (Coolant temperature sensor),Plausibility (P0115)
P202D B11/4 (refrigerant temperature sensor),reliability (P0115)

P2007 check B11/4 (coolant temperature sensor). Dynamic check implausible.
P2007 check B11/4 (coolant temperature sensor). Signal voltage too high.
P2007 check B11/4 (coolant temperature sensor). Signal voltage too low.

This source has them as:
P202D Mercedes-Benz Reductant Leakage
P202C Mercedes-Benz Reductant Tank Heater Control Circuit High
P2007 Mercedes-Benz Intake Manifold Runner Control Stuck Closed Bank 2

I cleared the codes, drove the car today and none of them came back. However, the low coolant level light is still on...
From what I've read there should be a magnet inside of coolant tank where sensor gets its reading from.
I'll disconnect the coolant reservoir on the weekend and give it a nice flush with detergent to see that maybe the magnet got stuck in it... Also I will check the coolant level sensor with a meter to make sure it functions and if it doesn't help and if I have time I'll dig into the windshield washer tank area and check sensor over there too.
Attached Files
File Type: pdf Mercedes Trouble OBD II codes.pdf (143.6 KB, 41 views)
ajberrow and 07slk280 like this.
JaysonM is offline  
#20 Old 03-16-2014
Registered Users
 
Join Date: Feb 2010
Location: Santa Monica CA
Vehicle: Black 2002 SLK AMG
Other Toys: Red 1965 Mustang convertible 4bbl V-8, 4spd
Posts: 843
Country:
Chats: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 221
Thanked 216 Times in 142 Posts
Garage
great thread!

for the last two weeks my coolant light has been flickering on and off. coolant level is/was normal and no leaks. Car was not running hot at all until...

Yesterday (saturday) caught in beach traffic on PCH in Malibu. Stop and go for about 10 minutes and the coolant temp gauge really started climbing. Turned the cabin heat to max and pulled over at the chart house. While there, my car cooled off and traffic went away. So the drive home was uneventful and the temps stayed in the every normal range. So I figured my radiator, thermostat and coolant were fine, and suspected the cooling fan or the cooling fan fuse.

Couldn't find a fuse for the cooling fan in the main fuse box, so I searched google for SLK32 cooling fan fuse and found this thread. And then, of course, found the fuse location quickly (thank you OP!). the fuse looked ok, but still checked napa and pep boys for a replacement, but they don't carry a fuse like that for Mercedes.

Decided to jumper past the fuse and see if the fan would spin when the engine was hot and the ac was on, but it was "no go" for fan being on with the jumper. Decided to get a multimeter for further detective work. Found 32 volts at the fuse and after the fuse. As the op said, this fuse assembly get voltage even with the ignition off. so with the ignition still off spun the fan a full revolution by hand and it seemed to turn fine. Then disconnected the wiring to the fan at the connector on the drivers side of the radiator. Checked the wiring at that point and got 32 volts! Then plugged the connector back together and the fan immediately started turning. So I thought: possibly bad electrical connector? Took the car for a spin with the ac on, and the coolant light stayed off, but only for about 5 minutes. And then went back to its flickering on and off state. Came back home and with the car idling in the driveway and the coolant temp about 8C above normal checked under the hood. Fan was not running and when I opened the electrical connection, this time I had no voltage in the wiring to the fan.

ugh, either bad wiring with an intermittent fault somewhere between the fuse and the electrical connection to the fan OR the control module is failing (mostly in a failed state for the last 2 weeks except for that strange 10 minute period about an hour ago when it all worked.

fun fun fun...will update when I know more
Santamonica SLK32 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
blower fan not working 1997 slk 230 peteslk SLK R170 General Discussion 56 08-22-2016 08:06 AM
Cooling fan troubles roachdoggslk SLK R170 General Discussion 9 06-12-2015 07:11 AM
New to site, looking for help w/aux cooling fan Scooter65 SLK R170 General Discussion 2 03-24-2012 10:26 PM
Cooling Fan. refaller SLK R170 General Discussion 2 01-14-2012 07:48 AM
Is my radiator fan working Chevytriker SLK R170 General Discussion 0 10-26-2010 03:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome