HELP! ABS/BAS/ESP warning lights on and top problem - Mercedes Benz SLK Forum
SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 09-15-2008
SLK World Junior Member
 
Join Date: May 2008
Posts: 6
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
HELP! ABS/BAS/ESP warning lights on and top problem

Hi everyone,

Full Problem Explained:

Just yesterday, I noticed that my ABS/BAS and ESP warning lights were lit up on my instrument cluster. I also noticed that once the car was parked and I wanted to put my top up, the switch to put the top up would flash red and the top would not go up as normal. I checked all the things that would make it flash normally like the shade in the trunk not being in place or the trunk open, etc, and everything was as it should be, so I am guessing that all of these things are somehow related.

I did however notice that once I turn the car off, then turn the key to the point right before your crank the car (when ALL lights are lit up on the instrument cluster) I was able to put the top up as normal. Today I was testing things out and when I first got into the car, I was able to put my top up and down as normal with the car running (before driving anywhere) but after having driven for 5 minutes, I was back to turning the car off and then the key to the point right before your crank the car (when ALL lights are lit up on the instrument cluster) before I was able to put the top up as normal

Before I go nuts and make my first visit to my local MB dealership, is there any easy quick fix techniques I should look into or anything I should check (ex. fuses, etc) to see if its something silly that is causing the problem (and to avoid paying an arm and half a leg at the MB dealership for something silly).

P.S. -- yes, I have done a few quick searches, and I have tried turning the steering wheel all the way the right then left when the car is on to "reset" things -- unless I was doing something wrong, that did not work -- also in my searches, I have not seen anyone with the top up problem I seem to have, so maybe that problem will clue someone into what is going on?


Cliff Notes Version:

ABS/BAS and ESP warning lights are lit up on instrument cluster
top does not go up when car is running, have to turn car off and then turn key to the point before the engine cranks (when all lights are lit up on instrument cluster) -- top will go up then. What is wrong and how do I fix?

Thank you to anyone who can help or shed some light on this topic. Sorry for the long post!

||SLK320||

Last edited by ||SLK320||; 09-15-2008 at 07:50 PM. Reason: added info
||SLK320|| is offline  
Sponsored Links
Advertisement
 
#2 Old 09-15-2008
Founding Member #7
 
mtiede's Avatar
 
Join Date: Jun 2006
Location: Western New York
Vehicle: 2006 SLK 350
Posts: 2,087
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 261
Thanked 146 Times in 96 Posts
Isn't there a menu choice somewhere that let's you choose the max speed at which you can operate the top? Maybe that is set to zero? Just guessing...
mtiede is offline  
#3 Old 09-16-2008
Founding Member #2

 
etyu's Avatar
 
Join Date: Jun 2006
Location: Orange County, CA
Vehicle: 2008 SLK 55
Posts: 17,806
Country:
Chats: 11
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 4,400
Thanked 2,851 Times in 2,056 Posts
Garage
I don't think //SLK320// has the SmartTop module.

Eddy



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Pewter(cubanitsilber metallic)/Beige, PIII package, Airscarf, Hands-Free Communication System, Lighting package; Designo Black Leather Cover on e-brake handle(Thank you Bill T), SmartTop v3.x, John's 3BFM, M113 AMG OEM air filters, Modified R170 ant., clear side-markers & front parking lamps w/error-free LEDs, chromed front & rear turn indicator lamps, steel mesh at battery bay cover & cabin air intake, sock-over-seatbelt buckles, belt-loop guide protectors, Lamin-X fog lamp protectors, bilateral rear fog lamps enabled, etched ///AMG logo on gear shift knob by Blackrose-etching
etyu is offline  
#4 Old 09-16-2008
Founding Member #7
 
mtiede's Avatar
 
Join Date: Jun 2006
Location: Western New York
Vehicle: 2006 SLK 350
Posts: 2,087
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 261
Thanked 146 Times in 96 Posts
The smarttop let you set it for more than 9mph, but I thought I remembered the 320 allowing you to set a speed too. Just slower speeds. But my memory is worth less and less as the days pass
mtiede is offline  
#5 Old 03-10-2009
SLK World Member
 
Join Date: Mar 2009
Location: daventry england
Vehicle: slk320
Posts: 15
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
you need a new brake light switch
EDD57 is offline  
#6 Old 04-02-2009
SLK World Member
 
Join Date: Apr 2009
Location: Manchester UK
Vehicle: SLK 320
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 1 Time in 1 Post
You get it fixed? Coz ive had the same or similar problem for almost a year now. I've been to Independents and the main dealer - they have changed, the brake switch located under the foot pedal, the front left brake sensor, and a steering angle sensor under the dash. I have also replaced the battery and checked all the wiring arounnd the ASR module. I've lost track of the times the faults which show up on diagnostics have been cleared. I've posted upteen requests on another forum and got little back in the way of help. Looks as though the same goes for this forum from the responces you have had.
Hope you have better luck than me - my car 2000 year SLK320 is booked in to another mercedes dealer for next thursday. I dont honestly think it will get fixed now. If it doesnt, then it's going - ive had enough of it. (
HarrySolomon is offline  
#7 Old 04-02-2009
Thread Hijacker
 
dmjonez's Avatar
 
Join Date: Aug 2008
Location: Kennesaw, GA
Vehicle: formerly 2001 SLK320, and 2006 55AMG. Shopping again.
Other Toys: MB E550 4matic, MB C300, Saab 9-3, PT Cruiser, Ram 1500, 737-700/800
Posts: 2,799
Country:
Chats: 1599
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 652
Thanked 781 Times in 401 Posts
Send a message via Yahoo to dmjonez Send a message via Skype™ to dmjonez
Quote:
Originally Posted by HarrySolomon View Post
You get it fixed? Coz ive had the same or similar problem for almost a year now. I've been to Independents and the main dealer - they have changed, the brake switch located under the foot pedal, the front left brake sensor, and a steering angle sensor under the dash. I have also replaced the battery and checked all the wiring arounnd the ASR module. I've lost track of the times the faults which show up on diagnostics have been cleared. I've posted upteen requests on another forum and got little back in the way of help. Looks as though the same goes for this forum from the responces you have had.
Hope you have better luck than me - my car 2000 year SLK320 is booked in to another mercedes dealer for next thursday. I dont honestly think it will get fixed now. If it doesnt, then it's going - ive had enough of it. (
We could use a little more information. Specifically which codes do you get? The light is always on, or intermittent? Never any relief or improvement, even after the visit to the garage? No guarantee for their work? Can you start from the beginning and go through the whole issue, as there may be some small point that solves the entire problem...


dj
dmjonez is offline  
#8 Old 10-17-2010
SLK World
 
Join Date: Jun 2009
Location: Bexhill on Sea UK
Vehicle: 1998 230SLK
Other Toys: Nissan Elgrand, 1960 Vauxhall Victor
Posts: 19
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
I have exactly the same problem on my 230SLK, has anybody given you any other ideas as to what it could be. The ABS and other warning lights are on all the time, and the hood goes up sometimes, but another time it wont. I would be pleased if you could throw any light on this problem
Thanks Chris
Chris42 is offline  
#9 Old 10-17-2010
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG
Posts: 34,923
Country:
Chats: 38
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 190 Post(s)
Thanks: 1,986
Thanked 5,456 Times in 3,800 Posts
chris, fyi last post was over a year ago


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Premium 1, Multimedia, Lighting packages
Kleemann ECU Tune, headers and downpipes
Thread here:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Llumar (Clear Bra) Paint Protective Film
OEM MB Plexiglass
Clear Side Markers w/amber LED bulbs
LED Parking and License Plate Bulbs
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#10 Old 10-17-2010
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K 1986 560SL 2012 VW Tiguan
Posts: 9,603
Country:
Chats: 27
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Thanks: 678
Thanked 943 Times in 814 Posts
Garage
Hey Chris this is an old thread but have a look at the K40 board for bad solder joints, check the main oil tank in the boot which controls the roof it may be low on oil. Have a look at the PSE pump in the boot, if its wet that could be one of the problems with the roof. If all looks good then you may have a bad limit switch for the roof.
Livefreeordie is offline  
#11 Old 06-05-2011
SLK World
 
Join Date: Jun 2009
Location: Bexhill on Sea UK
Vehicle: 1998 230SLK
Other Toys: Nissan Elgrand, 1960 Vauxhall Victor
Posts: 19
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Took the car to an Independent Garage and they did a diagnostic test, told me that the ring on the end of the drive shaft had broken, that was causing the ABS lights to come on. They phoned Mercedes and were told that you cannot buy the ring on it's own, have to buy the whole drive shaft (£625). I came home and looked online at Mercedes scrap dealers, and found one for £40 + £18 postage. Ordered it, came within 3 days, I then took it to the garage they charged me £120 to put it on, that included MOT, so I was well pleased with that.
Chris42 is offline  
#12 Old 03-12-2013
Elite SLK World Member
 
DavidJB's Avatar
 
Join Date: Mar 2013
Location: Lancashire,England
Vehicle: 2013 SLK250CDI Palladium Silver
Other Toys: cameras,golf clubs,fly fishing rods and reels
Posts: 259
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 52
Thanked 18 Times in 17 Posts
Garage
Ok I had exactly the same problems on an SLK 230 Roadster several years ago,Did the usual brake switch.wheel sensor checks and changes but did not solve the problem. It used to clear itself then soon came back again.
Had it in to an independent Merc specialist garage who had the car for test drives and checks for about a week. Eventually after lots of false alarms they traced the problem to a faulty solenoid on the end of the crankshaft.Apparently a seal had failed and allowed oil to seep past the solenoid and migrate along the electrical wiring loom up to the ECU.They fitted a new solenoid ,new wiring loom and managed to dry out the oil that had got onto the pcb components and solenoids inside the ECU thankfully.
I also had to have a new IFZ control unit and new PSE pump at the same time,do not know whether these faults were caused by the faulty wiring loom or not but suspect they were all interelated.
The total bill for parts and labour which included recovery to their garage, diagnostic tests,starter line and new ignition door key was £2,086.27 inc VAT.This all happened in March 2010. I reckon I got away lightly with the bill.
DavidJB is offline  
#13 Old 03-12-2013
Registered Users
 
robbiemarcelo's Avatar
 
Join Date: Feb 2013
Location: subic bay Freeport zone, Philippines
Vehicle: 1997 slk230 Linarit Blue
Posts: 39
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 5 Times in 4 Posts
Quote:
Originally Posted by mtiede View Post
Isn't there a menu choice somewhere that let's you choose the max speed at which you can operate the top? Maybe that is set to zero? Just guessing...
Do the slk230 have a setting where you can put the top up when moving? mine needs to be fully stopped before you can operate the top.
robbiemarcelo is offline  
#14 Old 03-12-2013
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG
Posts: 34,923
Country:
Chats: 38
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 190 Post(s)
Thanks: 1,986
Thanked 5,456 Times in 3,800 Posts
that is what the smarttop mod does for you:

http://www.slkstore.com/product.php?...cat=268&page=1

Remote control of convertible top - open and close your convertible top using the original factory remote control key fob.
Passive mode - allow factory test equipment to be utilized without causing irregularities in their read-outs.
Extra chirp signal function - when operating the power locks, the horn sounds once briefly. (this can be turned off)
Open/Close top while driving - open and close the top while driving up to 38 mph.
Individually programmable - configure features/functions of the smartTOP module to meet your personal preferences.
One Touch Top - 'one touch' convertible top operation allows you to open and close automatically.
Extra top convenience mode - turning the ignition on or off does not interrupt convertible top operations.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Premium 1, Multimedia, Lighting packages
Kleemann ECU Tune, headers and downpipes
Thread here:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Llumar (Clear Bra) Paint Protective Film
OEM MB Plexiglass
Clear Side Markers w/amber LED bulbs
LED Parking and License Plate Bulbs
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#15 Old 07-11-2013
SLK World Junior Member
 
Join Date: Sep 2012
Location: Reading, UK
Vehicle: SLK 230 Kompressor, Polar White with Mondrian Blue/Black leather
Other Toys: Mini Cooper S
Posts: 8
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
Same thing has just happened to me...ASR/ABS light on = no top mechanism.

Merc garage diagnosed wheel motion sensor faulty. Part on order - just need it quick as the sun is shining !!
Always Wanted One is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now

In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




  LinkBacks (?)
LinkBack to this Thread: http://www.slkworld.com/slk-r170-general-discussion/7381-help-abs-bas-esp-warning-lights-top-problem.html
Posted By For Type Date
forum mercedes abs | VIRGILIO Ricerca | Web This thread Refback 11-07-2008 08:41 AM

Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
BAS/ ESP light on Miss B SLK R170 General Discussion 5 08-20-2009 10:27 PM
BAS ESP Caption mun802 SLK R170 General Discussion 8 04-02-2009 03:48 PM
ABS+BAS+ESP Error??? diclehana Ask DansSLK 3 03-05-2009 12:36 PM
any harm in daily driving w/ ESP/ABS/BAS fully disabled? jameslk55 Ask DansSLK 5 02-28-2009 01:54 AM
PLEASE HELP ME ??? VSS/ check engine / ABS, EPS,BAS SLKlady Help and Support 6 11-14-2008 08:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome