Throttle response problem - Mercedes Benz SLK Forum
SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2016
Location: Ireland
Vehicle: SLK 200 Kompressor (R170) 2002
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 18
Thanked 1 Time in 1 Post
(Thread Starter)
Throttle response problem

Hi everyone,

Bit of a problem with my SLK 200 (2002) (manual).

My mechanic installed a new sump gasket and gave it an oil change. Apparently to get access to the sump he had to lower the engine off it's mounts, disconnect the exhaust (intake manifold I assume?), disconnect the anti-rollbar etc.

He later performed a weld on an exhaust bracket under the car and the battery was disconnected for a while.

Then when the the new gasket and oil change was done, he took the car for a 10 minute drive and everything was fine. But when he was driving back into the workshop the car started revving up and down on it's own and the throttle pedal no longer has any effect when pushed in, so the car is no longer driveable.

He says there is an engine management light on and when the car is started up it idles at about 1500 rpm and then revs up and down on it's own.

He is going to try his diagnostic tool, but he is not a Mercedes mechanic so I don't know if his tool/ software will yield any useful results.

The oil we put in was the correct type for the car.

Does anyone know what the fault might be?

Thanks
Silverado77 is offline  
Sponsored Links
Advertisement
 
#2 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2016
Location: Ireland
Vehicle: SLK 200 Kompressor (R170) 2002
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 18
Thanked 1 Time in 1 Post
(Thread Starter)
UPDATE - The mechanic is getting the diagnostics code P0638

Car is revving up and down of it's own volition between 1500 and 2000 RPM
Silverado77 is offline  
#3 Old 1 Week Ago
Premium Member

 
WoZ53's Avatar
 
Join Date: Feb 2016
Location: Eureka, California
Vehicle: 2006 280 SLK Caspian Blue Metallic
Posts: 2,904
Country:
Chats: 0
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 218 Post(s)
Thanks: 185
Thanked 271 Times in 225 Posts
Garage
Quote:
Originally Posted by Silverado77 View Post
UPDATE - The mechanic is getting the diagnostics code P0638


https://www.engine-codes.com/p0638.html

Welcome to the forum
Where search is your friend
and the info never ends



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Tim Wozny/ WoZ
Eureka,CA
WoZ53 is online now  
The Following User Says Thank You to WoZ53 For This Useful Post:
 
#4 Old 1 Week Ago
Registered Users
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2011 Smart Car CDI,Blue.
Posts: 190
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 0
Thanked 31 Times in 20 Posts
I would go over the Wiring Connectors under the Bonett with a "fine tooth comb". Remove and reconnect all of them.

When the Engine has been disturbed that much, wires may have been put under stress and it only takes a fraction of a mm to lose connection.

Mike
ixion is online now  
The Following User Says Thank You to ixion For This Useful Post:
#5 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2016
Location: Ireland
Vehicle: SLK 200 Kompressor (R170) 2002
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 18
Thanked 1 Time in 1 Post
(Thread Starter)
Thanks Mike,

Do you know if there is a throttle sensor somewhere near the exhaust manifold?
Silverado77 is offline  
#6 Old 1 Week Ago
Registered Users
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2011 Smart Car CDI,Blue.
Posts: 190
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 0
Thanked 31 Times in 20 Posts
It is built into the throttle pedal.
ixion is online now  
The Following User Says Thank You to ixion For This Useful Post:
#7 Old 5 Days Ago
Registered Users
 
Join Date: Jun 2016
Location: Ireland
Vehicle: SLK 200 Kompressor (R170) 2002
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 18
Thanked 1 Time in 1 Post
(Thread Starter)
My mechanic said his diagnostic tool gave him the option to reset the throttle. The car has been driving trouble free so far for 60 miles. I will continue to monitor it throughout the coming week.
Silverado77 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
SLK R171 not starting duncanadamsxxx SLK R171 General Discussion 12 3 Weeks Ago 04:53 AM
Acceleration problem SPIDEY CY SLK R170 General Discussion 3 07-17-2016 05:19 PM
Intermittent Starting Problem edzed SLK R171 General Discussion 32 01-05-2016 06:21 AM
Conductor Plate Problem; shady service rep... What to do? Th3120ck General Discussion 35 02-12-2012 04:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome