SLK230 power loss, surge - Mercedes Benz SLK World Forum
Mercedes Benz SLK World ForumSLKWorld.com The World's Premier Mercedes Benz SLK Community
 

Go Back   Mercedes Benz SLK World Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion
SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

SLKWorld.com is the premier Mercedes-Benz SLK Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-18-2012   #1 (permalink)
SLK World Junior Member
 
Join Date: Feb 2011
Location: Maryland
Vehicle: '03 230SLK
Other Toys: 1967 MG Midget
Posts: 8
Country:
Chats: 0
Thanks: 1
Thanked 0 Times in 0 Posts
Default SLK230 power loss, surge

Not clear if there is a connection between the two, but the engine surges around 300 rpm at rate of about once per 2 seconds when feathering the throttle, and seems to have a noticeable loss of power from about half to full throttle. Surges when idling in park about 600 - 1000 rpm for a while and then settles to 700 steady. Check engine light is on and coolant level light comes on intermittently. Odometer is now 105K. Any ideas as to whats going on here?
View pmatocha's Photo Album pmatocha is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-20-2012   #2 (permalink)
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K 1986 560SL 2012 VW Tiguan
Posts: 9,070
Country:
Chats: 27
Thanks: 639
Thanked 915 Times in 786 Posts
Garage
Default

Pull the codes and post them here, maybe we can help.
View Livefreeordie's Photo Album Livefreeordie is offline   Reply With Quote Quick reply to this message
Old 12-20-2012   #3 (permalink)
Senior SLK World Member
 
Birds's Avatar
 
Join Date: Dec 2011
Location: Left Coast
Vehicle: 05 350
Posts: 170
Country:
Chats: 0
Thanks: 9
Thanked 26 Times in 24 Posts
Default

Bad gas, fuel filter?
View Birds's Photo Album Birds is offline   Reply With Quote Quick reply to this message
Old 06-04-2013   #4 (permalink)
SLK World Junior Member
 
Join Date: Aug 2012
Location: Southern Ca, USA
Vehicle: 2003 SLK0230
Posts: 2
Country:
Chats: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Default

What did the problem turn out to be?


I've got exactly the same symptoms.

Surging while cruising. Like a "tug" every second or so.
Stumbling/surging at idle. 300-1K.

If I turn the engine off and restart, it will have gone away, so the dealership never sees it and can't fix it

I once got CEL with P0101.
Replaced the MAF, cleaned oil sep in compressor muffler (air intake).
No change.

It doesn't do it everyday. And never when it's at the dealership.

It's disconcerting/annoying on the highway.
When braking to a stop it feels errily/scary when it's tugging you as you come to a stop.
Then at idle, it will stutter to 300 and then surge to 1K, back and forth about once per second.
View RicksterSLK's Photo Album RicksterSLK is offline   Reply With Quote Quick reply to this message
Old 06-04-2013   #5 (permalink)
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG
Posts: 32,183
Country:
Chats: 38
Thanks: 1,900
Thanked 5,190 Times in 3,565 Posts
Default

RicksterSLK,

Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t already.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’.

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.

Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response and only once. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message) - capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click on the ‘paper clip’ or go to ‘advanced’ and then ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’!
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Also vote or enter our Ride of the Month competition: http://www.slkworld.com/rotm-submissions-voting/

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Premium 1, Multimedia, Lighting packages
Llumar (Clear Bra) Paint Protective Film
OEM MB Plexiglass
Clear Side Markers w/amber LED bulbs
LED Parking and License Plate Bulbs
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
View jbanks15's Photo Album jbanks15 is online now   Reply With Quote Quick reply to this message
Old 06-05-2013   #6 (permalink)
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Thanks: 14
Thanked 124 Times in 110 Posts
Default

Quote:
Originally Posted by RicksterSLK View Post
What did the problem turn out to be?


I've got exactly the same symptoms.

Surging while cruising. Like a "tug" every second or so.
Stumbling/surging at idle. 300-1K.

If I turn the engine off and restart, it will have gone away, so the dealership never sees it and can't fix it

I once got CEL with P0101.
Replaced the MAF, cleaned oil sep in compressor muffler (air intake).
No change.

It doesn't do it everyday. And never when it's at the dealership.

It's disconcerting/annoying on the highway.
When braking to a stop it feels errily/scary when it's tugging you as you come to a stop.
Then at idle, it will stutter to 300 and then surge to 1K, back and forth about once per second.
Answer with a question; do these cars have an Exhaust Gas Recirculation Valve? These are used to cool teh exhaust gasses to reduce NOx emissions, and work under part throttle.
Typical effect is to cause a pause in acceleration as you pass 1500 revs, but if controlled erratically, would have the effect you describe.

Seems strange to use hot exhaust gasses to cool the exhaust gas flow; it actually puts inert nitrogen into the inlet manifold, so there is lots of gas but less oxygen to burn, so teh cylinder flame temp is decreased, and hence the NOx generation (which happens at high flame temps) is decreased.
Why is the exhaust gas only nitrogen? Because the right amount of fuel has been put in to burn all the oxygen in the previous cycle!

HTH.
View Tolak's Photo Album Tolak is online now   Reply With Quote Quick reply to this message
Old 03-26-2014   #7 (permalink)
SLK World Junior Member
 
Join Date: Sep 2009
Vehicle: SLK 230 K R170 98
Posts: 2
Country:
Chats: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Default

sorry for bringing up an old thread... what was the problem and did u find the solution in the end? does it have to do with the charcoal canister thing at the fuel line...?
View bikz's Photo Album bikz is offline   Reply With Quote Quick reply to this message
Old 03-26-2014   #8 (permalink)
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG
Posts: 32,183
Country:
Chats: 38
Thanks: 1,900
Thanked 5,190 Times in 3,565 Posts
Default

bikz,

Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t already.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’. Profile is NOT updated in your ‘garage’.

We’d like you to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already. http://www.slkworld.com/new-members-...yourself-here/


Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response and only once. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Post your vin in the Vehicle Datacard Request section to get a datacard (options on your car) free.
Also vote or enter our Ride of the Month competition: http://www.slkworld.com/rotm-submissions-voting/

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Premium 1, Multimedia, Lighting packages
Llumar (Clear Bra) Paint Protective Film
OEM MB Plexiglass
Clear Side Markers w/amber LED bulbs
LED Parking and License Plate Bulbs
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
View jbanks15's Photo Album jbanks15 is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mercedes Benz SLK World Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your images to ImageShack

Register Now

In order to be able to post messages on the Mercedes Benz SLK World Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!!2001 slk230 Power Steering pipe googlem SLK R170 General Discussion 2 05-14-2012 06:26 AM
SLK230 Black Leather Heated and Power Adjustable Seats 1998-2004 slkparts SLK Parts For Sale 6 04-28-2012 04:01 PM
Loss of power again... new IC pump, no blown fuse :( DaytonaJae Ask DansSLK 28 06-24-2011 09:00 PM
loss of power Foxy Ask DansSLK 10 11-06-2010 04:08 PM


All times are GMT -4. The time now is 09:00 AM.


 
 
 

Powered by vBulletin Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO
Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
SLKWorld 2006-2010
Design by Fife Web Solutions


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276