Charging problem - Mercedes Benz SLK Forum
SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 03-19-2011
SLK World Junior Member
 
Join Date: Mar 2011
Location: Seattle, WA
Vehicle: 1998 SLK 230
Posts: 4
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Charging problem

My 1998 SLK 230 tried to die in traffic when I was running all accessories on a stormy night (wipers, fan, defogger, headlamps, radio). I limped to a parking lot and came back with a new battery.

After testing the alternator and seeing only 12V while running, I changed out the voltage regulator. No change: still only 12V (11.5 under medium load). I removed the alternator and had it bench tested. 14V + . Put it back on the car. 12V. Revved up the engine. No change. 12V (11.5 under medium load).

The car starts and drives fine and all electrical accessories function but I just know it's going to strand me again when the battery is unable to keep up with demand.

Anyone run into this before? Why the hell does the alt work fine outside the car but not in it?

Ernie
erniel2 is offline  
Sponsored Links
Advertisement
 
#2 Old 03-19-2011
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K 1986 560SL 2012 VW Tiguan
Posts: 9,435
Country:
Chats: 27
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 661
Thanked 934 Times in 805 Posts
Garage
Welcome from New Hampshire
Livefreeordie is offline  
#3 Old 03-19-2011
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG
Posts: 34,126
Country:
Chats: 38
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 144 Post(s)
Thanks: 1,953
Thanked 5,379 Times in 3,732 Posts
erniel2,

Welcome from Valrico, Florida!
And welcome to this great forum!


You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.





If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member or guest will address your question.
If you wish to PM (Private Message) someone, you need 15 posts. To get those 15 posts quickly, just go to the ‘new members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Premium 1, Multimedia, Lighting packages
Kleemann ECU Tune, headers and downpipes
Thread here:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Llumar (Clear Bra) Paint Protective Film
OEM MB Plexiglass
Clear Side Markers w/amber LED bulbs
LED Parking and License Plate Bulbs
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#4 Old 03-19-2011
Registered Users
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 350
Posts: 1,056
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Thanks: 74
Thanked 160 Times in 134 Posts
Hmm... I'd check the cables, and the grounds between the engine and body. What's your VIN, I'll look up where these are.
efair is offline  
#5 Old 03-19-2011
Elite SLK World Member
 
Join Date: Jun 2010
Location: neither here nor there but in hawaii
Vehicle: I like it a lot
Other Toys: dirtbikes
Posts: 321
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 36 Times in 26 Posts
check the electrical connections such as the ground, battery terminals and alternator itself.

Also highly possible that the alternator is on its way out. They tend to fail in stages, and not all at once. You could try seeing if the battery holds a charge overnight to see if the battery is the culprit.
rya96797 is offline  
#6 Old 03-25-2011
SLK World Junior Member
 
Join Date: Mar 2011
Location: Seattle, WA
Vehicle: 1998 SLK 230
Posts: 4
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Not sure where to post this so I'll continue the dialogue here.

Replaced Alt, battery, and K56 crach seperation relay. Alt is charging 19V at the gen post of the relay but the battery side of the relay only sees 12V (less under load).

So I know for a fact the alt is working and the battery is known good. What would cause the brand new relay to fail to pass the charge along to the battery?
erniel2 is offline  
#7 Old 06-25-2011
SLK World Junior Member
 
Join Date: Jun 2011
Location: Chesapeake
Vehicle: 1998 SLK 230
Posts: 4
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 1 Time in 1 Post
Voltage regulator 1998 SLK230

Voltage regulator 1998 SLK230
I did go to Autozone & the voltage regulator is bad. Where do you get one?? Link or phone number to a vendor that actully has one. What are part numbers. People that look on these forums are here because someone has sucessfully done this job, are you out there - I need voltage regulator part number that can be purchased - found plenty of links to vendors that after you get to their site do not have any for my car. Number on the old regulator returns nothing in searching on the net. Who knows where to get a voltage regulator for a 1998 SLK230, help! Part number on my current Bosch voltage regular is 1197311533 - can not find it or a replacement part number.
mkressgold is offline  
#8 Old 06-25-2011
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG
Posts: 34,126
Country:
Chats: 38
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 144 Post(s)
Thanks: 1,953
Thanked 5,379 Times in 3,732 Posts
mkresgold,

Welcome to the World’s Premier Mercedes-Benz SLK Community from Valrico, Florida!


Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’.

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.






If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member or guest will address your question.

Thank you,
Jeff
Founding Member/Sergeant-at-Arms/Moderator


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Premium 1, Multimedia, Lighting packages
Kleemann ECU Tune, headers and downpipes
Thread here:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Llumar (Clear Bra) Paint Protective Film
OEM MB Plexiglass
Clear Side Markers w/amber LED bulbs
LED Parking and License Plate Bulbs
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now

In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
r170 200k start problem EGOONE Ask DansSLK 9 02-14-2012 03:52 PM
99 SLK 230 Charging Problem Nanner General Discussion 1 07-30-2010 04:11 PM
Dead battery and auto gearbox problem... kole301 SLK R170 General Discussion 9 07-21-2010 09:48 AM
gearbox problem DevonSLK Ask DansSLK 6 06-30-2010 05:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome