Engine stumbling when first starting in the morning - Mercedes Benz SLK World Forum
Mercedes Benz SLK World ForumSLKWorld.com The World's Premier Mercedes Benz SLK Community
 

Go Back   Mercedes Benz SLK World Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion
SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

SLKWorld.com is the premier Mercedes-Benz SLK Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 07-06-2010   #1 (permalink)
SLK World
 
Join Date: Mar 2010
Location: Florida
Vehicle: 2000 SLK230 Kompressor
Other Toys: 2001 Land Rover Disc., 2008 Land Rover LR2 , 2006 Pro-line 36' Sportfish, 1981 Piper Comanche Twin
Posts: 13
Country:
Chats: 0
Thanks: 0
Thanked 1 Time in 1 Post
Default Engine stumbling when first starting in the morning

I have a 2000 SLK230 and suddenly I've experienced trouble when first starting the car after it has sat overnight. The car used to start up smoothly on a high idle and then after letting it warm up, it would idle down and work fine.

Now when I start it, it stumbles on low idle and if I press the accelerator pedal, it simply stumbles worse until to stops running. I've had to work and work to get it going in the morning for the past several days, so I'm assuming that something has gone wrong. It's like the choke system is not working for some reason.

Any ideas what could have happened? Is this a fuse problem or do I have some kind of system component problem?

thanks
View benzer101's Photo Album benzer101 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-06-2010   #2 (permalink)
Premium Member
 
Durkatlon's Avatar
 
Join Date: Nov 2009
Location: San Diego, CA
Vehicle: 2006 SLK350
Posts: 3,924
Country:
Chats: 0
Thanks: 340
Thanked 1,118 Times in 648 Posts
Garage
Default

I've had these symptoms with an old Ford Escort I used to drive when cylinders started conking out. This was ultimately traced to a leak in a seal, causing coolant to enter the engine block.
View Durkatlon's Photo Album Durkatlon is offline   Reply With Quote Quick reply to this message
Old 07-06-2010   #3 (permalink)
Elite SLK World Member
 
Join Date: Jan 2010
Location: Simi Valley, CA
Vehicle: 2006 SLK55
Posts: 657
Country:
Chats: 0
Thanks: 9
Thanked 208 Times in 115 Posts
Garage
Default

Does it still stumble once warmed up?
Any codes?

Did you check the intake system AFTER the MAF? Look for leaks, loose clamps.
Did you try cleaning the MAF. (CRC MAF cleaner)
Look for loose plug wires and/or cracked plugs too.
View Todd157k's Photo Album Todd157k is offline   Reply With Quote Quick reply to this message
Old 07-06-2010   #4 (permalink)
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG
Posts: 32,354
Country:
Chats: 38
Thanks: 1,902
Thanked 5,204 Times in 3,575 Posts
Default

benzer,

Please update your location/vehicle (model and yr) in your profile as it helps the members answer any questions you might have based on locale and model and year.
Usercp at the top of page, edit your details, location/vehicle.

You might want to post an introduction in the ‘new members introduce yourself here’ section, if you haven’t already.

If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before.
In addition, if you haven’t, please post your questions in the appropriate discussion forum for a quicker response.Be patient and a knowledgeable member or guest will address your question.
And finally, if you find something useful on your visit here today, perhaps something that saved you time or money, please consider becoming a donating member or make a one-time donation to offset development and operating costs. Even $5 is welcome! At the top of the page, click ‘Donate’ and then ‘Donate now’. Thanks!
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Premium 1, Multimedia, Lighting packages
Llumar (Clear Bra) Paint Protective Film
OEM MB Plexiglass
Clear Side Markers w/amber LED bulbs
LED Parking and License Plate Bulbs
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
View jbanks15's Photo Album jbanks15 is online now   Reply With Quote Quick reply to this message
Old 05-28-2011   #5 (permalink)
SLK World
 
Join Date: Jan 2011
Location: Washington, DC
Vehicle: 2000 SLK 230
Posts: 20
Country:
Chats: 0
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via Skype™ to westrava
Default

I wish I could help, but I have the exact same problem on my 2000 with 70k miles on it.

If I start it up and drive right away the transmission kicks in first gear and again in second gear. Then it's fine the rest of the time.

If I start it up and wait for about a minute, I can drive off with no problems with the lower gears, smooth as could be.

If anyone else has had this problem, and a fix, I'd love to know.

Thanks.

--Randy
View westrava's Photo Album westrava is offline   Reply With Quote Quick reply to this message
Old 05-28-2011   #6 (permalink)
Senior SLK World Member
 
Join Date: May 2010
Location: South West
Vehicle: SLK 230K sport, 99', Silver, 60K miles
Posts: 100
Country:
Chats: 0
Thanks: 0
Thanked 9 Times in 9 Posts
Default

Quote:
Originally Posted by westrava View Post
I wish I could help, but I have the exact same problem on my 2000 with 70k miles on it.

If I start it up and drive right away the transmission kicks in first gear and again in second gear. Then it's fine the rest of the time.

If I start it up and wait for about a minute, I can drive off with no problems with the lower gears, smooth as could be.

If anyone else has had this problem, and a fix, I'd love to know.

Thanks.

--Randy
I also have this problem. I put it down to either a need for new transmission fluid or a sensor starting to wear out somewhere.
View Captainrave's Photo Album Captainrave is offline   Reply With Quote Quick reply to this message
Old 05-28-2011   #7 (permalink)
Moderator - Founding Member ROTM Coordinator

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG
Posts: 32,354
Country:
Chats: 38
Thanks: 1,902
Thanked 5,204 Times in 3,575 Posts
Default

almost a year since the original poster asked his query.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, Retired US Army Master Sergeant
2009 SLK 55 AMG Black/Black
Premium 1, Multimedia, Lighting packages
Llumar (Clear Bra) Paint Protective Film
OEM MB Plexiglass
Clear Side Markers w/amber LED bulbs
LED Parking and License Plate Bulbs
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
View jbanks15's Photo Album jbanks15 is online now   Reply With Quote Quick reply to this message
Old 05-28-2011   #8 (permalink)
Fanatical SLK World Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: 1998 SLK230, 171,xxx miles
Posts: 3,080
Country:
Chats: 0
Thanks: 718
Thanked 455 Times in 358 Posts
Garage
Default

Quote:
Originally Posted by westrava View Post
I wish I could help, but I have the exact same problem on my 2000 with 70k miles on it.

If I start it up and drive right away the transmission kicks in first gear and again in second gear. Then it's fine the rest of the time.

If I start it up and wait for about a minute, I can drive off with no problems with the lower gears, smooth as could be.

If anyone else has had this problem, and a fix, I'd love to know.

Thanks.

--Randy
Its not a problem, its the way the ecu works
when the engines fluids etc are warmed up it lets you drive normally.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
OK for Mac

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Vario roof
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

SLK
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
View leapyfish's Photo Album leapyfish is offline   Reply With Quote Quick reply to this message
Old 06-15-2011   #9 (permalink)
SLK World
 
Join Date: Dec 2010
Location: Miramar, FL
Vehicle: 2000 SLK 230 Kompresspr Conv
Posts: 42
Country:
Chats: 0
Thanks: 2
Thanked 6 Times in 5 Posts
Garage
Default

Same thing happened to me. Turned out to be the Injector Coils. They are located under the red cap on the engine. You dont necessarily need to buy both but there is no way of telling which one isnt working unless you hook the car up to the Computer. Buy them and replace them yourself. Really easy job. And the car is running like normal again
View Juanbamf's Photo Album Juanbamf is offline   Reply With Quote Quick reply to this message
Old 07-19-2011   #10 (permalink)
SLK World Member
 
Join Date: Apr 2009
Location: Tonawanda, NY
Vehicle: 1999 slk 230 Kompressor
Other Toys: Morgan OI51 sailboat, formerly owned many airplanes as I owned an air freight operation
Posts: 12
Country:
Chats: 0
Thanks: 6
Thanked 0 Times in 0 Posts
Default

I have the same problem, and then my CEL comes on mabe ten miles later... I disconnected my battery for about 5 minutes and then the car started normal for about 2 days and of course went back to the rough start... Very annoying.. Don S.
View don33764's Photo Album don33764 is offline   Reply With Quote Quick reply to this message
Old 08-06-2011   #11 (permalink)
SLK World
 
Join Date: Jan 2011
Location: Washington, DC
Vehicle: 2000 SLK 230
Posts: 20
Country:
Chats: 0
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via Skype™ to westrava
Default

Thanks Juanbamf, my issue was with the injector coils too. I replaced the spark plugs, still had the stumbling problem when engine was cold. Found injector coils online for $57 each, brand new. Replaced both injector coils and tada, no engine problems.

--Randy
View westrava's Photo Album westrava is offline   Reply With Quote Quick reply to this message
Old 08-06-2011   #12 (permalink)
Fanatical SLK World Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: 1998 SLK230, 171,xxx miles
Posts: 3,080
Country:
Chats: 0
Thanks: 718
Thanked 455 Times in 358 Posts
Garage
Default

Quote:
Originally Posted by don33764 View Post
I have the same problem, and then my CEL comes on mabe ten miles later... I disconnected my battery for about 5 minutes and then the car started normal for about 2 days and of course went back to the rough start... Very annoying.. Don S.
If the CEL is on get the codes read!
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
OK for Mac

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Vario roof
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

SLK
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
View leapyfish's Photo Album leapyfish is offline   Reply With Quote Quick reply to this message
Old 08-09-2011   #13 (permalink)
SLK World
 
Fyrelight's Avatar
 
Join Date: Jun 2011
Location: Fortuna, California
Vehicle: 2000 SLK 230 -- Designo Orange
Other Toys: No Toys, just Tools.
Posts: 73
Country:
Chats: 0
Thanks: 24
Thanked 16 Times in 10 Posts
Garage
Default I learn a lot here . . . usually http://www.slkworld.com/images/smilies/smile.gif

Injector coils???? . . . never heard of such a thing . . . will put them on the list for replacing . . . new owner of an 11 year young SLK so looking for how to make it better

Thanks
View Fyrelight's Photo Album Fyrelight is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mercedes Benz SLK World Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your images to ImageShack

Register Now

In order to be able to post messages on the Mercedes Benz SLK World Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY - Engine mounts replacement for post facelift R170 Mantist SLK R170 class DIY 7 05-24-2014 01:05 PM
AMGPL: AMG 5.5-litre V8 biturbo engine Cold Shot AMGs 14 03-21-2010 09:11 AM
E 430 Amg dltslk Mercedes Benz Posers 4 04-02-2008 11:36 AM
Mercedes Benz DiesOtto Engine MarkR171 Off Topic 3 07-26-2007 08:05 PM
models and prices SLKman General Discussion 23 02-09-2007 04:02 AM


All times are GMT -4. The time now is 07:05 AM.


 
 
 

Powered by vBulletin Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO
Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
SLKWorld 2006-2010
Design by Fife Web Solutions


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276